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1  Introduction 1 

1.1  Purpose 2 

QXDM Professional™ (QXDM Pro) provides a diagnostic client for Dual-Mode Subscriber 3 

Station (DMSS) and newer User Equipment (UE) software, Advanced Mobile Subscriber 4 

Software (AMSS). 5 

QXDM Pro was developed to provide a rapid prototyping platform for new diagnostic clients and 6 

diagnostic protocol packets. It provides a Graphical User Interface (GUI) that displays data 7 

transmitted to and from the DMSS. 8 

NOTE: The use of DMSS in this document refers loosely to user equipment that is connected to QXDM 9 

using the Qualcomm Technologies, Inc. (QTI) diagnostic interface. 10 

1.2  Scope 11 

This document is intended for users of QXDM Pro who need to know how to install, use, and 12 

understand the information provided by QXDM Pro. Many features for specific diagnostic clients 13 

supported by QXDM are documented elsewhere. Applicable documents are referenced in  14 

Table 1-1. Additionally, features added since this revision are documented in the Release Notes 15 

for the software release in which the feature was added and can be referenced via the Start→ 16 

Programs→QXDM Professional→ReadMe file.  17 

1.3  Conventions 18 

Function declarations, function names, type declarations, and code samples appear in a different 19 

font, e.g., #include. 20 

Code variables appear in angle brackets, e.g., <number>. 21 

Commands to be entered appear in a different font, e.g., copy a:*.* b:. 22 

Button and key names appear in bold font, e.g., click Save or press Enter. 23 

Shading indicates content that has been added or changed in this revision of the document. 24 
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1.4  References 1 

Reference documents are listed in Table 1-1. Reference documents that are no longer applicable 2 

are deleted from this table; therefore, reference numbers may not be sequential. 3 

Table 1-1  Reference documents and standards 4 

Ref. Document 

Qualcomm Technologies 

Q1 CDMA Dual-Mode Subscriber Station Serial Data Interface Control 
Document 

80-V1294-1 

Q2 Factory Test Mode cdma2000 Test Commands 80-V5849-1 

Q3 gpsOne Position Determination Messaging and Parameters 80-V0726-1 

Q4 Serial Interface Control Document for WCDMA 80-V2708-3 

Q5 Application Note: Software Glossary for Customers CL93-V3077-1 

Q6 QXDM Database Editor User Guide 80-V9396-1 

Q7 Qualcomm ISF Processing Interfaces 80-V5627-1 

Q8 Obtaining Support for QXDM 80-VD384-1 

NOTE: See Section 2.4.3 for access to QXDM Pro documentation. 5 

1.5  Technical assistance 6 

For assistance or clarification on information in this document, submit a case to QTI at 7 

https://support.cdmatech.com/. 8 

If you do not have access to the CDMATech Support Service website, register for access or send 9 

email to support.cdmatech@qti.qualcomm.com. 10 

1.6  Acronyms 11 

For definitions of terms and abbreviations, see [Q5]. 12 

80-V1241-21 YL 17 Confidential and Proprietary – Qualcomm Technologies, Inc. 
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  

 

https://support.cdmatech.com/
mailto:support.cdmatech@qti.qualcomm.com


 

2  Installation 1 

2.1  Required hardware and software 2 

QXDM Pro is designed to be installed and run on workstations running Microsoft Windows 2000 3 

Service Pack 1 or higher, Windows XP, and Windows Vista operating systems. Support is not 4 

provided for Windows NT and Windows 9X variants. 5 

NOTE: QXDM Pro requires Microsoft Internet Explorer 6.0 or higher and QPST Server Ver 2.7, Build 6 

200 or higher (QPST 2.7.200). For convenience, QPST is included with QXDM on CD-ROM or 7 

can be installed separately over network installations. 8 

2.1.1  Minimum system requirements 9 

The minimum required configuration for QXDM is described in Table 2-1. 10 

The extensibility features of QXDM Pro enable it to support unlimited configurations including 11 

support for end user-defined applications. A minimum configuration necessarily means that less 12 

work can be done simultaneously. Multiple instances of QXDM Pro, other running (including 13 

background) processes, and having too many views open at the same time may require more than 14 

the minimum system configuration listed below. 15 

Table 2-1  Minimum system requirements 16 

Item Description 

CPU 800 MHz Pentium III class 
RAM 256 MB 
Hard drive Installation requires 30 MB. Logging requires min 20 MB free disk space. Note that 

some of today’s phones are capable of generating log data in excess of 18 MB  
per minute. 

Operating system Windows 2000 Service Pack 1, Windows XP, Windows Vista 
Port connections One USB or serial I/O port per device (phone, FFA, SURF™, or GPS receiver) 
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2.2  Installing QXDM Pro 1 

The QXDM Pro software is provided either over the network or on CD-ROM. 2 

The installer sets up the QXDM Pro execution environment, which includes installing application 3 

binaries, data files, and documentation; registering COM automation components and file 4 

associations; and configuring QXDM Pro for initial use. 5 

The QXDM Pro installation consists of two main folders: 6 

 QXDM program folder – The path to this folder is set by the user when installing QXDM. 7 

The default path offered by the installer is based on the underlying Microsoft operating 8 

system program files folder, which is typically C:\Program Files\Qualcomm\QXDM.  9 

After installation, this folder will contain subfolders containing the QXDM binaries, the 10 

QXDM documentation, and parsing DLL wizards for the Microsoft Visual Studio 11 

development environment. The contents of this folder should be considered read-only. 12 

 QXDM data folder – The base path to this folder is set by the underlying Microsoft operating 13 

system and represents the documents folder shared by all users of the host PC. Typically, the 14 

Microsoft Windows shared documents folder is located at  15 

C:\Documents and Settings\All Users\Documents. After installation, this folder will contain a 16 

Qualcomm\QXDM subfolder. The resulting complete path represents the QXDM data folder. 17 

A shortcut to this location named “QXDM Data” is located in the Start Menu under the 18 

“QXDM Professional” group. Under this will be several subfolders containing QXDM 19 

automation script samples, the QXDM database, implementation files for all QXDM 20 

HTML-based displays, temporary QXDM item store format files, user-submitted QXDM 21 

extensions, reference dynamic parsing DLLs, and the reference QTI vendor database. Unlike 22 

the program folder, the QXDM data folder is designed to accommodate user extensions, such 23 

as a user database or a user authored QXDM HTML display. 24 

Two folders are utilized in order to be compliant with the current Microsoft Windows Logo 25 

Program requirements. 26 

The installer creates a QXDM Pro folder in the Windows Start Programs menu that can be run by 27 

selecting Start→All Programs→QXDM Professional→QXDM Professional. The installed 28 

application binaries and user guides are accessible from this location. Additionally, a shortcut to 29 

the QXDM Pro data folder is installed.  30 

NOTE: Attempting to install QXDM Pro by running the QXDMInstaller.msi file is not supported. The 31 

only supported means of installing QXDM Pro is via the setup.exe program. 32 

2.2.1  Installing from CD-ROM 33 

1. From the Windows desktop, select Start → Run → D:\Setup.exe. Specify the drive letter of 34 

your CD-ROM. 35 

2. Press Enter. 36 

2.2.2  Installing over the network outside QTI 37 

Follow the instructions provided by QTI for installing QXDM Pro from the Documents and 38 

Downloads website. 39 
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2.2.3  QLMS activation 1 

In some versions of QXDM, a one-time online activation is required before QXDM can be run 2 

using Qualcomm License Management System (QLMS). Follow the instructions provided by QTI 3 

to activate your copy of QXDM. 4 

2.2.4  WIBU dongle usage 5 

In some versions of QXDM, support for the WIBU dongle protection key system is available as a 6 

replacement for QLMS. WIBU dongle support requires the following: 7 

 WIBU dongle runtime environment – The WIBU runtime environment can be installed by 8 

following the instructions located at http://wibu.com/download_user.php?lang=en 9 

 QTI-programmed WIBU dongle protection key 10 

 Qualcomm License File (QLF) that matches the above WIBU dongle protection key installed 11 

to the QXDM data folder (typically located at  12 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM) 13 

2.3  Physical connectivity 14 

QXDM Pro connects to a phone or SURF through the QPST Server using a serial or USB cable 15 

to a COM port on your PC, as illustrated in Figure 2-1. 16 

 17 

Figure 2-1  Physical connectivity 18 

2.4  Overview 19 

2.4.1  Installation path 20 

The QXDM Pro installation consists of two main folders. See Section 2.2 for more information.  21 

80-V1241-21 YL 20 Confidential and Proprietary – Qualcomm Technologies, Inc. 
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  

 

http://wibu.com/download_user.php?lang=en


 Installation 

2.4.2  QXDM Tools Suite 1 

The tools shown in Figure 2-2 are installed with QXDM Pro and can be accessed from the 2 

Windows Start menu. Commonly used tools are also available through the QXDM Pro Tools 3 

menu. 4 

 5 

Figure 2-2  Start Menu – QXDM Pro Tools Suite 6 

2.4.2.1  Database Editor 7 

The Database Editor provides an interface to describe user-defined items using QXDM Pro user 8 

databases. For complete documentation see [Q6], which is available through the Database Editor 9 

Help menu. 10 

2.4.2.2  DLF Converter 11 

The DLF Converter converts legacy DLF log files into ISF log files that can be loaded into 12 

QXDM Pro for analysis. Command line support is also provided using the following syntax: 13 

 14 

DLFConverter <DLF Input Filename> <ISF Output Filename> 15 

2.4.2.3  ISF Converter 16 

The ISF Converter converts ISF log files into legacy DLF log files for third-party DLF parsing 17 

support tools. Command line support is also provided using the following syntax: 18 

 19 

ISFConverter <–pc> <ISF Input Filename> <DLF Output Filename> 20 

 21 

The first option instructs the application to write out a PC timestamp in the generated log header 22 

for each item that does not contain a target timestamp. 23 

2.4.2.4  Item Tester 24 

The Item Tester is useful for viewing and testing items that are described in QXDM Pro 25 

databases. It also provides legacy script command examples for all items described in the QXDM 26 

Pro and user databases (see Section 7.2). 27 
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2.4.2.5  Listen-Only QXDM 1 

Running Listen-Only QXDM starts QXDM Pro in a Listen-Only mode. QXDM Pro will not send 2 

configuration commands to the target when started this way. 3 

2.4.2.6  PPP Extractor 4 

PPP Extractor converts PPP logs generated by the phone to the format specified in RFC 1662. 5 

This tool is provided for legacy targets and operates by processing each of log code pairs in 6 

Table 2-2 to a file in the PPP dump format. 7 

Table 2-2  PP Extractor operation 8 

Log codes (Rx, Tx) Description 

0x109C, 0x109D Legacy PPP logs 
0x1113, 0x1123 UM interface legacy PPP logs 
0x1114, 0x1124 RM interface legacy PPP logs 
0x1115, 0x1125 AN interface legacy PPP logs 

NOTE: The tool will generate a file regardless of whether any instances of the above log code pairs exist 9 

in the ISF file being processed. If not, the generated file or files will be empty and should not be 10 

loaded into a network protocol analyzer application. 11 

For newer targets, the QXDM Pro data protocol logging display and PCAP generator tool 12 

included with QCAT should be used instead of the PPP Extractor. 13 

2.4.2.7  QXDM Professional 14 

Selecting QXDM Professional causes the main QXDM Pro application to run. 15 

2.4.2.8  RPC Proxy 16 

This tool is used as a RPC-like proxy server for physical layer tests using an internal QTI 17 

proprietary interface. 18 

2.4.3  QXDM documentation 19 

The documents described in this section are installed with QXDM and can be accessed from the 20 

Windows Start menu. [Q8] is also available through the QXDM Pro Help menu. 21 

2.4.3.1  Qualcomm ISF Processing Interface 22 

[Q7] provides documentation for the postprocessing and analysis automation interface that 23 

supports both dynamic parsing DLLs and user database definitions (with preference towards the 24 

latter as it provides a richer interface). This interface does not differ in any substantial way from 25 

the real-time automation interface QXDM Pro utilizes to implement roughly 60% of the existing 26 

QXDM Pro displays. 27 
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2.4.3.2  QXDM Database Editor User Guide 1 

[Q6] describes how to use the Database Editor to provide packet item definitions for real-time 2 

QXDM parsing support. This document is available through the Database Editor Help menu. 3 

2.4.3.3  ReadMe 4 

Revision changes for each version of QXDM are detailed in the ReadMe file. 5 

2.5  Item Store Format (.ISF) files 6 

While running, QXDM Pro generates a temporary log file called the Item Store, which ensures 7 

that data is not lost in the event of unexpected program termination. Under normal circumstances, 8 

this file is deleted upon termination. The Item Store is created in the QXDM ISF folder (typically 9 

located at C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\ISF). 10 

The Item Store contains all traffic that occurs between QXDM and the target (or targets if QXDM 11 

sequentially connects to more than one target in a given session) or since the last time the Item 12 

Store was cleared, e.g., via the Clear Items (Ctrl + I) menu command. This provides an accurate 13 

representation of the state of the application at any given time for analysis and debugging. 14 

2.5.1  Always-On logging 15 

QXDM Pro is always generating an ISF log file. Log files can be processed by QXDM Pro at a 16 

later time for postprocessing analysis and replay. Always-On logging behavior can be customized 17 

from the Item Store Settings command. 18 

The Application Statistics view is the place to go for monitoring the status of logging 19 

(Section 4.5.1). 20 

NOTE: An ISF conversion utility is included with QXDM and is available from the Tools menu (Tools→ 21 

ISF File Converter) for backward compatibility with third-party tools that support only the legacy 22 

.dlf log file format. 23 

 24 

Conversion between formats is a destructive process, i.e., information in the ISF will be lost (e.g., 25 

per-item PC timestamps and per-item parsing hints). 26 

2.5.2  Recovering the Item Store 27 

If for some reason QXDM Pro is terminated abnormally, the session can be recovered. 28 

Section 3.1.6 describes how to load an ISF file. In the event of abnormal termination, it may be 29 

possible to recover and repair the lost session. The temporary ISF is located in the QXDM ISF 30 

folder. 31 

2.5.3  Saving the Item Store 32 

By default, the ISF is deleted upon QXDM Pro termination. If you wish to save a session for later 33 

analysis or viewing, select Enable Query For ISF Save (see Figure 3-9). 34 

 35 
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3  Display Overview 1 

QXDM Pro uses a multiple document interface to support any number of views simultaneously. 2 

3.1  File menu 3 

These options are available through the File menu selection. 4 

 5 

Figure 3-1  File menu options 6 

3.1.1  Annotate 7 

Predefined strings can be appended to the ISF using this command (see Section 2.5). Users can 8 

override default annotation strings by including a UserAnnotation.txt table in the Microsoft 9 

Windows shared documents folder for all users typically located at  10 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\Database. To replace 11 

existing annotations described in Annotation.txt, copy one or more lines using a text editor like 12 

Notepad and save the changed text in a file named UserAnnotation.txt. 13 

NOTE: Do not edit the Annotation.txt file directly, as it is overwritten each time QXDM is installed. 14 
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3.1.2  Dynamic Parsers 1 

QXDM supports the addition of dynamic parsers that the end user can provide to parse items. 2 

Refer to Chapter 9 for information on creating runtime parsers. Use the Parsing Engines window 3 

to tell QXDM where to look to load these parsers (see Figure 3-2). 4 

 5 

Figure 3-2  File→Dynamic Parsers… 6 
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3.1.3  View Registrations 1 

This tool views register interest in items when they are opened and unregisters when they are 2 

closed, e.g., opening the Finger Placement view results in registration for the Searcher Finger and 3 

Enhanced Finger Information logs. Figure 3-3 demonstrates using View Registrations to see what 4 

items have been registered by the current set of open Views. 5 

This view is also useful in determining if an item has been registered with the phone, e.g., if you 6 

have requested a log that the phone is not sending, check View Registrations. If the log is 7 

checked, then contact the responsible phone technology or build person for help in determining 8 

why the phone is not sending the log. 9 

 10 

Figure 3-3  File→View Registrations… 11 

3.1.3.1  Context options 12 

Additional context-sensitive options allow you to refine the controls and can be accessed by 13 

clicking the right mouse button over the view area to select the following items: 14 

 Only Show Supported Items – When checked, only items supported by the phone are 15 

displayed. 16 

 Utilize Categories – When unchecked, all items are shown in a single list; this can sometimes 17 

be helpful locating an item. 18 

 Copy Text – When selected, the registrations for the clicked item type are converted to text 19 

and copied to the clipboard. 20 
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3.1.4  Load Configuration… 1 

Previously saved configurations can be loaded using the Load Configuration command. 2 

Configurations such as selected views and registrations are restored from QXDM configuration 3 

files (.dmc extension). 4 

 5 

Figure 3-4  File→Load Configuration… 6 
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3.1.5  Save Configuration… 1 

Configurations remember selected view registrations and settings and can be saved to QXDM Pro 2 

configuration files (.dmc extension) for later loading. 3 

 4 

Figure 3-5  File→Save Configuration… 5 

3.1.6  New Items… 6 

New Items creates a new temporary .isf file. This is useful if you have been reviewing an existing 7 

file store (by loading or replaying it) and now want to connect to a live target without appending 8 

to the current file. This option can also be used to start a new .isf file in advance of commencing a 9 

test. 10 

NOTE: If the Enable Query For ISF Save option (Figure 3-9) has been set, QXDM Pro will prompt you 11 

to save the current temporary .isf file before creating a new ISF. If this option has not been set, 12 

the current temporary .isf file will be automatically deleted. 13 
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3.1.7  Load Items… 1 

NOTE: This command will be enabled only if QXDM Pro is not connected to a target. 2 

A previously saved .isf file can be loaded for viewing. 3 

 4 

Figure 3-6  File→Load Items… 5 
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3.1.8  Save Items… 1 

Save Items behaves exactly the same as New Items except that there is no check to see if Enable 2 

Query For ISF Save (Figure 3-9) is checked. 3 

 4 

Figure 3-7  File→Save Items… 5 

3.1.9  Replay Items… 6 

NOTE: This command will be enabled only if QXDM Pro is not connected to a target. 7 

A previously saved .isf file can be loaded for replaying using this command. 8 

 9 

Figure 3-8  Replay Items 10 
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3.1.9.1  Maximum Gap 1 

Set the maximum amount of time in milliseconds to wait before playing the next item. If the 2 

actual gap exceeds the configured value, the configured value will be used as the amount of time 3 

to wait until playing the next item. 4 

3.1.9.2  Playback Speed 5 

Set the speed at which items are played. 6 

NOTE: Using the No Wait option can impact system performance when views are open that process each 7 

and every item. 8 

3.1.9.3  Compact Layout 9 

Information about an item is displayed as it is processed unless Compact Layout is checked. 10 

3.1.9.4  Step 11 

To replay just one item, click Step. 12 

3.1.9.5  Play/Pause 13 

To replay based on the selected settings, click Play. To stop replaying, click Pause. 14 
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3.1.10  Item Store Settings… 1 

The Item Store Settings dialog allows the user to control ISF logging behavior. 2 

 3 

Figure 3-9  Item Store File Settings 4 

3.1.10.1  General Options 5 

The default behavior is for QXDM Pro to prompt for a log file name on user-initiated log file 6 

saves (e.g., File→Save Items, Section 3.1.8). 7 

3.1.10.1.1  Enable ISF Quick-Saving 8 

When Enable ISF Quick-Saving is checked, the log file is saved using the Base ISF Name at the 9 

ISF Directory location, without prompting the user for a filename. 10 

NOTE: This applies only to scenarios where the user has initiated the save, i.e., by selecting the Save 11 

Items menu command. In the other scenarios, where an ISF must be saved due to a parallel 12 

operation (New Items, Load Items, and exiting QXDM), the user may still be prompted for a 13 

filename (dependent on the mode). In all scenarios, an automatically generated name will appear 14 

in the prompt dialog itself. 15 
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3.1.10.1.1.1  Base ISF Name 1 

Use Base ISF Name to describe the unique portion of the ISF filename that will be used when in 2 

Advanced Mode. Using the base ISF name, QXDM Pro will format the name as follows: 3 

 4 

<Base Name>MM-DD-HH-MM.isf 5 

3.1.10.1.1.2  ISF Directory 6 

Use ISF Directory to describe where to save ISF files. The default is located in the Microsoft 7 

Windows shared documents folder for all users typically at  8 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\ISF. 9 

3.1.10.1.2  Automatic ISF Post-Processing 10 

Automatic postprocessing of log files is supported by providing a command and optional 11 

arguments that QXDM Pro will run each time a log is saved. The log is passed to the specified 12 

command by QXDM Pro. 13 

3.1.10.1.2.1  Command 14 

Enter the command including the fully qualified path that QXDM Pro is to run, e.g., 15 

C:\WINDOWS\System32\CScript.exe. 16 

3.1.10.1.2.2  Arguments 17 

Enter any required arguments for the command, e.g., C:\TestScripts\ISFAnalyzeLog1234.js. The 18 

format requirements are the same as if run from a command window, i.e., if the argument 19 

contains spaces, it should be enclosed in quotes. 20 

3.1.10.2  Mode Options 21 

The default logging mode is for QXDM Pro to delete the temporary log file upon program 22 

termination. 23 

3.1.10.2.1  Standard Mode 24 

Selecting Standard Mode results in the default behavior described above. 25 

3.1.10.2.1.1  Enable Query For ISF Save 26 

When this option is checked in Standard Mode, the user is prompted to save the temporary Item 27 

Store upon creating a new Item Store (New Items), loading an Item Store (Load Items), or before 28 

exiting. 29 
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3.1.10.2.2  Advanced Mode 1 

Selecting this option causes QXDM Pro to apply the advanced options described below. 2 

3.1.10.2.2.1  Maximum ISF Size 3 

Use Maximum ISF Size to set the maximum file size the current temporary ISF can reach before 4 

it is closed and a new temporary ISF is used. 5 

3.1.10.2.2.2  Maximum ISF Duration 6 

Use Maximum ISF Duration to control the maximum file duration (time between first item’s 7 

generic timestamp and last item’s generic timestamp) that can elapse before the current temporary 8 

ISF is closed and a new ISF is used. 9 

3.1.10.2.2.3  Automatic ISF Saving When Limits Reached 10 

This checkbox controls whether an ISF that has exceeded specified limits is automatically saved. 11 

If it is not checked, the temporary ISF is deleted when limits are reached. 12 

3.1.10.2.2.4  Maximum Archive Count 13 

Use Maximum Archive Count to control the maximum number of ISF files that will be saved. 14 

When this value is exceeded, the oldest ISF saved by the current QXDM process is deleted. 15 

3.1.11  Exit 16 

Click Exit to end the QXDM Pro session. 17 
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3.2  View menu 1 

This section discusses options available through the View menu selection. 2 

 3 

Figure 3-10  View menu 4 

3.2.1  New 5 

Use this option to select a view grouped by logical categories. 6 

3.2.2  Command Bar 7 

Select this option to display or hide the Command Bar. 8 

3.2.3  Status Bar 9 

Select this option to display or hide the Status Bar. 10 

3.2.4  View Bar 11 

Select this option to display or hide the View Bar. 12 
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3.3  Options menu 1 

This section discusses options available through the Options menu selection. 2 

 3 

Figure 3-11  Options menu 4 
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3.3.1  Communications 1 

The Communications dialog, shown in Figure 3-12, lists all ports in the system and the port 2 

properties, and allows users to choose the COM ports used by QXDM Pro for connection 3 

purposes. 4 

 5 

Figure 3-12  Options→Communications… dialog 6 
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3.3.1.1  All Ports in System 1 

A table lists all ports in the system and their properties, including Port Type, Port, State, Label, 2 

Phone, and Data Rate. 3 

If a port is checked and the Port Type is diagnostic, the port was added in the QPST 4 

Configuration tool and is monitored by the QPST Port Server. 5 

If a port is unchecked, it is not under the monitor of the QPST Port Server and is not in the QPST 6 

Configuration tool. 7 

By clicking the checkbox and changing the status between checked and unchecked, the port can 8 

be added to or removed from the QPST Port Server monitor (2 to 3 sec is needed to update new 9 

port information to the display). 10 

Double-click the blue globe in the Windows Task Bar, illustrated in Figure 3-13, to configure the 11 

ports that the QPST port server is monitoring. 12 

 13 

Figure 3-13  QPST configuration globe 14 

The QPST Configuration utility is shown in Figure 3-14. 15 

 16 

Figure 3-14  QPST Port Server configuration 17 

3.3.1.2  Edit Properties 18 

When you click the Edit Properties button in Figure 3-12, QXDM Pro displays a dialog to set the 19 

properties of a currently selected port. (The same function occurs when a port item in the table is 20 

double-clicked.) 21 

Only checked diagnostic ports can have labels to set. QPST detects phones connected to those 22 

ports and QXDM Pro displays them.  23 

Only unchecked ports can set data rates, which is especially important to the GPS port. Without 24 

the correct data rate setting, QXDM Pro might not recognize the GPS device and might read GPS 25 

information incorrectly. The GPS data rate may be located in the documentation provided with 26 

the GPS device. 27 
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3.3.1.3  Target Port 1 

Target Port lists the union of COM ports monitored by the QPST Port Server, which are the 2 

checked diagnostic ports in all ports in the system table. 3 

When a port is selected, QXDM Pro begins collecting information from the target board. 4 

3.3.1.4  GPS Server Port 5 

The GPS Server Port lists all COM ports that are not monitored by QPST.  6 

Select the COM port on which your GPS receiver is connected. QXDM Pro begins collecting 7 

GPS information from the GPS receiver when the connection is established. 8 

NOTE: QXDM Pro cannot identify the GPS port type if the port has been connected by another QXDM 9 

instance. However, customers can still connect to that port, since QXDM Pro lists all non-target 10 

ports in the GPS Server Port. 11 

 12 

Be sure to remove the COM port that your GPS receiver connects to from the list of ports that the 13 

QPST Configuration is monitoring. Otherwise, the COM port will not be visible to QXDM Pro. 14 

Select the Track Raw NMEA Sentences option to add raw NMEA sentences to the current ISF 15 

log file in addition to the finalized GPS information obtained by processing valid/recognized 16 

NMEA sentences. 17 

3.3.1.5  Timeouts (MS) 18 

Diag requests 19 

This is the time, in ms, that QXDM Pro waits for a reply from the phone to diag requests. 20 

NOTE: The maximum value QXDM Pro allows is 2000. The actual timeout is three times the value 21 

specified. The QPST Port Server automatically retries requests up to three times, so a timeout of 22 

2 sec translates to an actual net timeout of 6 sec. 23 

Script commands 24 

This is the time, in milliseconds, that QXDM Pro waits before timing out for legacy script 25 

commands. 26 
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3.3.2  Settings… 1 

This dialog allows you to set various personal preference settings. 2 

 3 

Figure 3-15  Options→Settings… dialog 4 
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3.3.2.1  Font Settings 1 

Using these font dropdown and size field, you can set the font face and size, specified in tenths of 2 

a point, that is used in all QXDM displays or specify the display components that use a fixed-3 

width font by default. This includes the following displays, display components, and dialogs: 4 

 Memory Viewer display 5 

 Task list pane of Task Profiling – APU/MPU displays 6 

 Dynamic Item List display 7 

 IS-95A Retrievable Parameters display 8 

 Each pane (scrolling list, raw item, and parsed item pane) of all item list-based displays 9 

(Command Output, Messages View, Log View, Item View, and Filtered View) 10 

 Raw Item Contents dialog 11 

A preview of the selected font is displayed in the preview pane. 12 

NOTE: The allowable range for the font face size is 80 to 240. 13 

 14 

If a font is not specified, the default font face used is Lucida Console and the default font size is 15 

taken from the current Microsoft Windows icon font size. 16 

 17 

It is not strictly necessary to choose a fixed-width font. For displays or display components that 18 

are designed around a fixed-width font, e.g., the Memory Viewer display, the font face selection 19 

will be ignored when a variable-width font is chosen. Instead, the default font face as given above 20 

will be used. 21 

3.3.2.2  Alternate Script Path 22 

This provides an alternate path from which to run scripts. The default is the QXDM application 23 

folder (typically C:\Program Files\Qualcomm\QXDM\bin). 24 

3.3.2.3  Build Source Path 25 

Use Build Source Path to supply a path that QXDM will search when a request is made to view 26 

the source file associated with a debug message (see Section 4.2.1.5.4). 27 

3.3.2.4  Vendor Database Path 28 

Use Vendor Database Path to supply a path that QXDM will use to locate a vendor’s database 29 

path. A vendor-specific database is used when parsing items specific to a particular handset 30 

vendor (currently only NV items). A vendor-specific database can also contain mobile model 31 

names. 32 

3.3.2.5  Protocol Categories/Revisions 33 

CDMA 34 

This is used to control the protocol revision utilized by QXDM when parsing CDMA OTA 35 

messages. Item Store files created by QXDM version 03.08.99 or later utilize the most recent 36 

CDMA protocol revision reported by the target. For these files (and real-time interaction), the 37 
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Automatic choice is the best selection. For files created by QXDM versions prior to 03.08.99 the 1 

option should be set to the appropriate protocol revision. 2 

NOTE: Utilizing the Automatic choice when viewing an ISF created by QXDM versions prior to 3 

03.08.99 is equivalent to choosing [06] – IS-2000 Rev 0. 4 

WCDMA 5 

This is used to control the protocol revision utilized by QXDM when parsing WCDMA Over-the-6 

Air (OTA) messages. Item Store files created by QXDM version 03.09.15 or later utilize the 7 

WCDMA protocol revision reported by the target. For these files (and real-time interaction), the 8 

Automatic choice is the best selection. For files created by QXDM versions prior to 03.09.15, the 9 

option should be set to the appropriate protocol revision. 10 

NOTE: Utilizing the Automatic choice when viewing an ISF created by QXDM versions prior to 11 

03.09.15 is equivalent to choosing 06/04 V5.9.0. 12 

HSDPA 13 

This setting allows you to control the HSDPA UE category used when the QXDM HSDPA 14 

displays need to map CQI indices to bit sizes. This value should match the UE category of the 15 

connected target. 16 

3.3.2.6  QXDM Title Bar Tag 17 

Specify a tag to differentiate separate instances of QXDM. The tag will appear in QXDM’s 18 

banner. 19 

3.3.2.7  Custom Shortcut Keys 20 

Use this option to select commands to run when the associated keys (F6 and F8) are pressed. 21 

80-V1241-21 YL 42 Confidential and Proprietary – Qualcomm Technologies, Inc. 
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  

 



 Display Overview 

3.3.3  DIP Switches… 1 

This option allows you to configure software DIP switch settings using the diagnostic services 2 

Get/Set DIP switch commands, as shown in Figure 3-16. Not all targets support this display. 3 

 4 

Figure 3-16  Options→DIP Switches… dialog 5 

3.3.4  Log View Config… 6 

NOTE: The legacy Log View has limited functionality and is provided only for backward compatibility. 7 

The correct approach is to use Always-On logging behavior in conjunction with Filtered Views. 8 

3.3.5  Message View Config… 9 

Although Message View Config is still supported, Filtered Views eliminate the need for a 10 

dedicated Message View Config dialog. 11 

NOTE: The legacy Messages View has limited functionality and is provided only for backwards 12 

compatibility. The correct approach is to use Filtered Views and configuration (.dmc) files. 13 
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3.3.6  Parsing Options 1 

Parsing Options allows you to control how QXDM Pro parses items. Using the options shown in 2 

Figure 3-17, you can control exporting parsed text and the order that QXDM Pro uses to select 3 

available parsing solutions. 4 

 5 

Figure 3-17  Parsing Options 6 

3.3.6.1  Export ANSI Text 7 

This menu item forces text exports to ANSI (as opposed to Unicode). 8 

3.3.6.2  Export Parsed Text 9 

Selecting this menu item enables the exporting of parsed text to a file or to the clipboard. Parsed 10 

text is any additional output generated by dynamic parsers like SILK and user-provided DLLs 11 

(see Chapter 9). 12 

3.3.6.3  Parsing DLLs, Default DB, User’s DB, QCAT 13 

Selecting this menu item causes QXDM to parse items in the following order preference: Parsing 14 

DLLs, QXDM database, User databases. 15 

3.3.6.4  Parsing DLLs, User’s DB, Default DB, QCAT 16 

Selecting this menu item causes QXDM to parse items in the following order preference: Parsing 17 

DLLs, User databases, QXDM database. 18 
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3.3.6.5  Default DB, User’s DB, Parsing DLLs, QCAT 1 

Selecting this menu item causes QXDM to parse items in the following order preference: QXDM 2 

database, User databases, Parsing DLLs. 3 

3.3.6.6  User’s DB, Default DB, Parsing DLLs, QCAT 4 

Selecting this menu item causes QXDM to parse items in the following order preference: User 5 

databases, QXDM database, Parsing DLLs. 6 

3.3.7  Auto-Launch Core Dump View 7 

Deselecting this menu item disables the automatic launching of the OS Core Dump View. By 8 

default, this is enabled so that on receipt of an OS Core dump log from supporting targets, the 9 

contents are displayed. 10 

3.3.8  Hide Hex Pane By Default 11 

Selecting this menu item causes the hexadecimal bytes display portion (lower left-hand pane) of 12 

filtered views to be hidden initially. 13 

3.3.9  Track Dropped Messages 14 

Selecting this menu item causes QXDM Pro to include dropped informational messages reported 15 

by the phone from each debug message response packet. 16 

3.4  Tools menu 17 

This is available through the Tools menu selection and provides a link to other installed tools. 18 

 19 

Figure 3-18  Tools menu 20 

This is available through the Window menu selection and allows you to manage active windows. 21 
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3.5  Window menu 1 

 2 

Figure 3-19  Window menu 3 

3.5.1  Tag Window 4 

By selecting this option, Filtered views can be tagged with user-customizable names. 5 

3.5.2  Clear Most 6 

Selecting this option will result in all views that support the Clear command being cleared, 7 

excluding the Item View. 8 

NOTE: The legacy Log View is unaffected by this command. 9 

3.5.3  Clear All 10 

Selecting this option will result in all views that support the Clear command being cleared. 11 

NOTE: Using this command will result in all data collected in a QXDM session being lost. 12 

3.5.4  Close 13 

When this option is selected, the window in focus will be closed. 14 
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3.5.5  Close All 1 

When this option is selected, all windows will be closed. 2 

3.5.6  Auto-Scroll All 3 

When this option is selected, all applicable windows will begin auto-scrolling. 4 

3.5.7  Arrange Icons 5 

When this option is selected, windows that have been minimized will be rearranged. 6 

3.5.8  Cascade 7 

When this option is selected, windows that are opened will be rearranged in a cascading order. 8 

3.5.9  Minimize All 9 

When this option is selected, all open windows will be minimized. 10 

3.5.10  Restore All 11 

When this option is selected, all minimized windows will be restored to their open settings. 12 

3.5.11  Tile Horizontal/Tile Vertical 13 

When this option is selected, windows that are opened will be rearranged in a vertical or 14 

horizontal fashion. 15 

3.5.12  Previous Window/Next Window 16 

When this option is selected, focus will be set to the next or previous logical window. 17 

3.5.13  Active Window List 18 

Active Window List displays all active windows. Clicking a window in this list will cause the 19 

focus to change to the selected window. 20 
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3.6  Help menu 1 

The Help menu provides access to licensing commands, as well as links to the QXDM Pro User 2 

Guide, the QXDM Release Notes, and the support information. 3 

 4 

Figure 3-20  Help menu 5 

3.6.1  Licensing 6 

Licensing allows you to view the status of the Qualcomm License Management System (QLMS) 7 

license. If you need to temporarily release the QXDM Pro QLMS license on the current 8 

computer, select Deactivate. 9 

NOTE: QLMS license deactivation requires an Internet connection. If you attempt to deactivate the 10 

QLMS license without an Internet connection, the license will be removed from the current 11 

computer but will still remain in the QLMS system. In this case, the only way to reclaim the 12 

license for use on another computer is to contact QLMS support and have the license manually 13 

removed from the QLMS system. 14 

3.7  View bar 15 

The View bar provides access to all views supported by QXDM Pro. 16 

 17 

Figure 3-21  View Bar 18 

3.8  Command bar 19 

The Command bar provides access to the legacy QXDM Pro command interface. 20 
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 1 

Figure 3-22  Command Bar 2 

3.8.1  Command interface 3 

Although many legacy DOS DM script commands are supported through the QXDM Pro 4 

command interface, the recommended approach for automated testing is to use the automation 5 

interface (see Chapter 8). 6 

Script commands can be typed in to the Command edit control. The Command Output display 7 

and the Item View display script output. Additionally, any Filtered View configured for the item 8 

type “Strings” and the item key “Automation” displays script output. 9 

3.8.1.1  Using filenames 10 

Some commands take filenames as arguments such as the Run command used to launch a script. 11 

To locate a file, QXDM Pro will use the following search criteria: 12 

1. Search using the file as provided 13 

2. Search using the installation default QXDM data path 14 

(C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM) 15 

3. Search using the Alternate Script path described in Options→Settings (Figure 3-15) 16 

3.8.2  Script Help for command interface 17 

The Script Help page documents all supported commands. It is available in the View combo-box 18 

from the View bar (Figure 4-1) This view also provides documentation for the legacy script 19 

commands that are part of the original DOS DM scripting interface. 20 

3.9  Status bar 21 

The Status bar displays a configurable subset of application statistics, application state indicators, 22 

and help for select menu commands. 23 

 24 

Figure 3-23  Status bar 25 
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3.9.1  Config… 1 

Right-clicking the Status bar brings up a dialog allowing you to configure which indicators the 2 

Status bar displays as well as the order of displayed indicators. 3 

 4 

Figure 3-24  Status Bar Config 5 

The status bar supports the indicators described in Table 3-1. 6 

Table 3-1  Status bar indicators 7 

Indicator Description 

Menu Command Help Help for the currently selected menu item (when available) 
Total Message Packets Total number of message packets added to current ISF log file 
Dropped Message Packets Total number of dropped message packets reported by target 
Last Received Timestamp Last target timestamp received 
DIAG Timeouts Total number of response timeouts when sending diag requests 
Bytes Received Total number of bytes received over COM port 
Bytes Transmitted Total number of bytes transmitted over COM port 
Packets Received Total number of packets received over COM port 
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Indicator Description 

Packets Transmitted Total number of packets transmitted over COM port 
RX Rate (Bytes) Rate at which data is being received over COM port 
TX Rate (Bytes) Rate at which data is being transmitted over COM port 
RX Rate (Packets) Rate at which packets are being received over COM port 
TX Rate (Packets) Rate at which packets are being transmitted over COM port 
ISF File Size Size of current ISF log file 
ISF Duration Amount of elapsed time current ISF represents 
ISF Read Errors Total number of errors reading an item from current ISF log file 
ISF Write Errors Total number of errors writing an item to current ISF log file 
Last Generic Timestamp Last generic (i.e., PC) timestamp generated 
Total Event Reports Total number of event reports added to current ISF log file 
Total GPS Reports Total number of GPS reports added to current ISF log file 
Total Log Packets Total number of log packets added to current ISF log file 
Event Reports Configured Is the target event service configured to generate traffic? 
GPS Reports Configured Is the QXDM GPS service configured? 
Log Packets Configured Is the target log service configured to generate traffic? 
Message Packets Configured Is the target debug message service configured to generate traffic? 
GPS Latitude Current GPS latitude (as reported by GPS receiver) 
GPS Longitude Current GPS longitude (as reported by GPS receiver) 
GPS Time Current GPS time (as reported by GPS receiver) 
QXDM Licensing Status Current number of days until license expires 

 1 
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4  QXDM Views 1 

4.1  QXDM views 2 

QXDM views are accessed from the QXDM Pro View bar, as shown in Figure 4-1. To display 3 

the View bar, select it within the View menu. 4 

 5 

Figure 4-1  QXDM views using the View bar 6 
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4.2  Item list views 1 

An item list view is a scrolling view that contains zero or more items that are derived from the 2 

contents of the current .isf log file. This includes the Item View, Filtered Views, the Messages 3 

View, the Log View, and the Command Output display.  4 

The Item View is a special item list view that shows all items generated during a QXDM session. 5 

When QXDM Pro is run, a temporary ISF is created in the QXDM ISF folder (typically located at 6 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\ISF). The Item View 7 

shows the contents of this temporary ISF log file and can be displayed from the View bar or by 8 

using the F11 accelerator key.  9 

A Filtered View represents a subset of the contents of the current .isf file and therefore the Item 10 

View. This subset is configured by item type and/or item key. Unlimited filtered views may be 11 

created by using the accelerator key F12 or selecting Filtered View from the View Bar. Filtered 12 

views can also be created by interacting with an existing item list based display through the 13 

Refilter Items, Match Items, and Process Items menu commands. 14 

For legacy reasons, the Messages View and Log View are preserved as special case Filtered 15 

Views. The Messages View is a Filtered View that can be configured from the main QXDM 16 

menu without being active. The Log View is similar to the Messages View in that it can be 17 

configured without being active. In addition to this behavior, the Log View implements additional 18 

functionality specific to legacy logging. 19 

The Command Output display is a special-case Filtered View whose configuration is fixed to 20 

accept only items whose type is String and whose key is Automation. Thus, the Command Output 21 

display shows all output from the legacy QXDM command interface and the preferred QXDM 22 

Pro automation interface. 23 

Excluding the legacy Messages View, Log View, and Command Output display, an item list view 24 

has three adjustable panes. The top pane is a scrolling list where a summary of each item in the 25 

view is displayed. The bottom left pane is used to display (in a hexadecimal dump) the raw data 26 

of the item currently selected in the scrolling list. The bottom right pane is used to display the 27 

parsed fields or (when available) the parsed text of the currently selected item in the scrolling list. 28 

4.2.1  Scrolling list pane 29 

All item list-based QXDM Pro displays contain the scrolling list pane. This includes the Item 30 

View, Filtered Views, the Messages View, the Log View, and the Command Output display. This 31 

pane displays each item in the view, one per line in the list. 32 
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4.2.1.1  Menu options 1 

Right-clicking within the scrolling list pane brings up the context-sensitive menu. 2 

 3 

Figure 4-2  Context-sensitive menu for Scrolling List Pane 4 

The context-sensitive menu is used to configure view registration, alter appearance, copy text, 5 

locate items, clear the view, and view raw item content. 6 
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4.2.1.2  Appearance 1 

Selecting this menu option lets you control the appearance of the scrolling list by selecting which 2 

item properties to display (in the form of columns), by specifying the order in which to display 3 

item properties, and by configuring item property specific options. 4 

 5 

Figure 4-3  Item List Appearance 6 

4.2.1.2.1  Timestamps 7 

The timestamp is shown in Greenwich Mean Time (GMT) and can be modified to include date 8 

and milliseconds. PC time or when available item-specific time can also be configured. PC time 9 

is the PC system time adjusted to GMT, at which an item is added to the Item Store. Item-specific 10 

time is the timestamp included in the packet received from the phone. Items that include phone 11 

timestamps are logs, events, debug messages, and the timestamp response packet. 12 

4.2.1.2.2  Payload 13 

By default, only the payload of an item is displayed when the Payload column is selected. Check 14 

Include Header Bytes to see the entire item content. 15 

80-V1241-21 YL 55 Confidential and Proprietary – Qualcomm Technologies, Inc. 
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  

 



 QXDM Views 

4.2.1.3  Configuration 1 

Selecting this menu option allows you to control which items are added to the view in question.  2 

The left side of the configuration dialog is used to identify what item types the filtered view will 3 

accept. The right side of the dialog is used to filter item type content based on item key and to 4 

register with the phone for items of interest. 5 

This configuration dialog is only supported by Filtered Views. The legacy Messages View and 6 

Log View use view-specific configuration dialogs discussed in subsequent sections. 7 

 8 

Figure 4-4  Item List Config dialog 9 

Items are grouped into types, as shown in Table 4-1. Item types allow QXDM Pro to classify 10 

incoming data from multiple sources: synchronous and asynchronous traffic between QXDM and 11 

a target, GPS receiver data, and internally generated strings. 12 

Table 4-1  Item types 13 

Item type Source 

Diag Malformed Packets Phone 
Diag Requests QXDM, User 
Diag Responses Phone 
Event Reports Phone 
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Item type Source 

GPS Reports GPS Receiver 
Log Packets Phone 
Log Packets (OTA) Phone 
Message Packets Phone 
Strings QXDM, User 
Subsystem Dispatch Requests QXDM, User 
Subsystem Dispatch Responses Phone 

4.2.1.3.1  Delayed Subsystem Responses Only 1 

Delayed Subsystem Responses Only, when selected, enables you to configure the view to receive 2 

only the delayed subsystem dispatch V2 responses (as opposed to both the immediate and delayed 3 

responses). Since both V2 and V1 responses are treated as the same item type, this makes certain 4 

types of filtering and item processing more convenient. 5 

4.2.1.3.2  Accept Unknowns 6 

Accept Unknowns, when selected, enables you to configure the view to receive items that are 7 

unrecognized. An item is considered unrecognized when no mapping between item type/key and 8 

item name exists in the QXDM Pro database and any loaded user database.  9 

4.2.1.4  Copying 10 

All or part of a filtered view output can be copied to a new ISF, a text file, or to the clipboard. 11 

The action is controlled by using any of the methods given in Table 4-2. 12 

Table 4-2  Copying items 13 

Item Description 

Copy Items Copy selected items to an Item Store Format (.isf) file 
Copy All Items Copy All Items to an Item Store Format (.isf) file 
Copy Text (Alt + C) Copy selected text to the clipboard 
Export Text (Alt + F) Export selected items as text to a file 
Export All Text (Alt + A) Export all items as text to a file 
Select All (Ctrl + A) Select all items 

 
Text output from loaded dynamic parsers, built-in OTA parsers, and extended database 14 

descriptions will also be copied if the menu item Options→Export Parsed Text is selected (see 15 

Section 3.3.7). 16 

Text output is subject to change. Use postprocessing tools, e.g., QCAT, to generate consistent text 17 

output for more reliable text processing results. 18 

All of the above operations, excluding copying text to the clipboard, result in the display of a 19 

progress dialog. This dialog displays the progress of the operation, statistics related to the 20 

operation, and any errors encountered in the process of the operation (such as errors reading an 21 

item from the current ISF or writing an item out to the new ISF). Additionally, the progress 22 

dialog allows you to cancel the operation before it has completed. In this case, the partial results 23 

are written out to the new ISF or text file. 24 
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 1 

Figure 4-5  Export To File Progress dialog 2 

4.2.1.5  Searching 3 

Each line in an item list view is the text representation of the properties of a particular item. This 4 

text can be searched to find an item that meets given search criteria. Additionally, each item in an 5 

item list view is associated with an index. This index can be used to jump to an item. For items 6 

with type Message Packets, additional information present in the content of the item can be used 7 

to locate the point in the target source code where the item originated. 8 
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4.2.1.5.1  Find 1 

Selecting this menu option (or using the Ctrl + F keyboard shortcut) allows you to search for text 2 

within the item list output. Both the type of item and the item properties to be searched can be 3 

configured. 4 

 5 

Figure 4-6  Find option for scrolling views 6 

4.2.1.5.1.1  Find options 7 

In addition to search direction, the following options are supported: 8 

 Include Full Parsed Text (When Available) – When this is selected, the search engine will 9 

also search the full parsed text that appears in the lower right-hand pane of the view. 10 

 RegEx Engine – The parser will accept regular expressions when JScript or Perl options are 11 

selected. Although support for JScript is included with the Windows operating system, Perl 12 

requires a separate installation. Documentation on regular expression syntax for these 13 

scripting languages is beyond the scope of this document. 14 

 Case Sensitive Search – By default, the search is case-insensitive. 15 
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 Inverted Search – When this is selected, the search engine will search for any pattern not 1 

matching the search criteria from the set of item types and item properties. 2 

 Start From Last Selection – By default, a new search is from the beginning of the file. 3 

Checking Start from Last Selection overrides this behavior. 4 

4.2.1.5.2  Find Next 5 

Find Next allows you to search for the next Find match. You can also execute this command by 6 

pressing Ctrl + N. 7 

4.2.1.5.2.1  Goto Item 8 

You can go to an item by specifying its index using the Goto Item command. When successful, 9 

QXDM will highlight the item at the index specified. You can also execute this command by 10 

pressing Ctrl + G. 11 

4.2.1.5.3  View Source 12 

View Source allows you to view the target source file associated with a selected item. You can 13 

also execute this command by pressing Alt + V. Use Options → Settings (see Section 3.3.2.3) to 14 

specify the search path used by QXDM Pro. 15 

4.2.1.5.4  Auto-Scroll 16 

When new items arrive and are added to an item list view, QXDM can automatically scroll to the 17 

end of the item list in order to display the new items, The Auto-Scroll menu option allows you to 18 

enable or disable this behavior. You can also control automatic scrolling by pressing Alt + S or 19 

by manually scrolling using the scroll bar, arrows, or Page Up and Page Down keys. 20 

4.2.1.6  Clear Items 21 

Clear Items allows you to flush all items from an item list view. You can also clear items by 22 

pressing Shift + Delete. 23 

Items can be cleared from any scrolling view except the Logging <Alt + L> View. Take care 24 

when clearing the Item View because doing so results in the current ISF being emptied and the 25 

connection being reset. 26 
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4.2.1.7  Match Items… 1 

Match Items allows you to create a new Filtered View based on a matched pattern from a selected 2 

set of items in an existing item list view. Configuring this process is nearly the same as 3 

configuring a find operation. 4 

 5 

Figure 4-7  Match Items 6 

The only difference is that the direction and selection options are not available. Instead, the 7 

operation starts from the first selected item in the current item list view and ends with the last 8 

selected item. 9 
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4.2.1.8  Process Items 1 

Process Items allows you to create a new Filtered View based on processing the selected items in 2 

an existing view with a user-provided script (Figure 4-8). The script can be written in any 3 

scripting language that supports the Microsoft Windows scripting engine interface model 4 

(IActiveScript). Examples of supported scripting languages are Perl, VB Script, and JScript. The 5 

contents of the user script must include a function named ProcessItem(), which accepts a single 6 

argument, an interface pointer to the QXDM item interface model (IColorItem) as shown in 7 

Table 4-3. 8 

 9 

Figure 4-8  Process With Script 10 

An example script, ProcessDelayedResponses.js, is provided in the QXDM Automation Samples 11 

folder – the automation samples are located in the QXDM Data folder described in Section 2.2 12 

(which is typically located in the Automation Samples subfolder of 13 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM). 14 

Table 4-3  ProcessItem() parameters 15 

Name Type Description 

Item IColorItem Refer to Section 8.3.14 for descriptions of supported commands for this interface 
 

ProcessItem() should return a Boolean value (VARIANT_BOOL) where true 16 

(VARIANT_TRUE) indicates the item passed to the function should be included in the new 17 

filtered view and false (VARIANT_FALSE) indicates the item should be discarded. 18 
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NOTE: The use of the VARIANT_BOOL COM type may not be directly supported in all scripting 1 

languages, in which case zero may be substituted for VARIANT_FALSE and a nonzero value 2 

may be substituted for VARIANT_TRUE. 3 

4.2.1.8.1  Process With Script options 4 

The options are: 5 

 Script Engine – Select the scripting engine to use from the available scripting hosts on 6 

your computer 7 

 Script Path – Specify the script file that will do the IColorItem processing 8 

 Types To Process – Select the item types your script is interested in processing 9 

4.2.1.8.2  Refilter Items 10 

Refilter Items allows you to create a new Filtered View from a selected group of items in an 11 

existing view based on item type and/or item key. Configuring the refilter operation is no 12 

different than configuring a Filtered View. 13 

 14 

Figure 4-9  Refilter Items 15 
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4.2.1.8.3  Raw Item 1 

This option displays the raw item contents in hexadecimal form for the currently selected item. A 2 

context menu can also be used to control the layout by clicking the right mouse button over the 3 

Raw Item Contents view. 4 

 5 

Figure 4-10  Raw Item menu 6 
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4.2.1.8.4  Sync Near Item 1 

Sync Near Item tries to find the item with the given index in all item lists. In each list, if the item 2 

with the given index is found, it is selected. If the item with the given index is not found, the item 3 

with the index closest to the specified index is selected. 4 

NOTE: It should be noted that item position correlates to generic timestamp, i.e., the item at index N has 5 

a generic timestamp that is earlier than the item at index N + 1, etc. In general, there is no 6 

correlation between item position and item-specific timestamps as they originate external 7 

to QXDM Pro. 8 

 9 

Figure 4-11  Sync Near Item 10 
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4.2.1.8.5  Sync To Item 1 

Sync To Item syncs all filtered views to the same selected item, if found. Sync To Item tries to 2 

find the item with the given index in all item lists. In each list, if the item with the given index is 3 

found, it is selected. If the item with the given index is not found, no change is made. 4 

 5 

Figure 4-12  Sync To Item 6 
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4.2.1.8.6  Bookmark Item 1 

  NOTE: This section was added to this document revision. 
2 

Bookmark Item marks selected items and adds them to the bookmark list view. To enter 3 

bookmark list view, click File→New→Common→Bookmark List View. 4 

To add a bookmark: 5 

1. Click File→Load Items and locate the ISF. 6 

2. Click View→New→Common→Item View (F11). 7 

3. Select any item you wish to bookmark and press ALT+B . Alternitively, right-click the item 8 

and select Bookmark Item. 9 

4. Click File→New Items to update the current ISF to include the bookmarks. 10 

5. Click File →Load Items and select the same ISF. 11 

6. Bookmarks will appear after about 1 sec (rows are highlighted). 12 

To navigate using bookmarks: 13 

1. Click File→Load Items and select an ISF that has bookmarks. 14 

2. Click View→New →Common →Item View (F11). 15 

3. Press ALT+U to navigate up the bookmark list or ALT+D to navigate down the list. 16 

NOTE: Navigation commands have no effect if the location of a bookmark is already being viewed and 17 

there are no additional bookmarks. 18 

Bookmarks are transferable as long as both PCs have the NTFS file system. If one PC 19 

does not have NTFS and a transfer is attempted, the bookmarks will be lost. 20 
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4.2.2  Raw Item pane 1 

The Item View and Filtered Views contain the Raw Item Pane. This pane displays the raw item 2 

contents in hexadecimal form for the item currently selected in the Scrolling List Pane. 3 

4.2.2.1  Menu options 4 

Right-clicking within the Raw Item Pane brings up the context-sensitive menu. 5 

 6 

Figure 4-13  Raw Item pane menu 7 
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4.2.3  Parsed Item pane 1 

The Item View and Filtered Views contain the Parsed Item pane. This pane displays the parsed 2 

fields or, when available, the parsed text of the currently selected item in the scrolling list pane. 3 

NOTE: Not all items have associated parsers to display parsed text in the parsed item pane. Item data is 4 

parsed using definitions in the QXDM database, SILK, and ASN.1 for OTA log items, or 5 

dynamic link parsers (DLLs) written by end users (see Section 3.1.1). 6 

4.2.3.1  Menu options 7 

Right-clicking within the Parsed Item pane brings up the context-sensitive menu. 8 

 9 

Figure 4-14  Parsed Item pane menu 10 
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4.3  HTML views 1 

QXDM Pro provides an IE browser framework to display HTML views that process and display 2 

data received from the connected SURF or FFA. This framework utilizes the QXDM COM 3 

automation interface. 4 

NOTE: The IQXDM interface is intended only for use with the scripting interfaces and is not supported 5 

in the HTML views. Use the IQXDM2 interface for HTML view development (see Section 8.2). 6 

HTML views are made accessible from the QXDM View Bar (Figure 3-21) when the following 7 

conditions are met: 8 

 The file must have the extension .HTML and be located in the QXDM HTML folder 9 

(typically installed at  10 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\HTML). 11 

 The file must contain the following meta elements defined within the head element: 12 

 DMViewName 13 

 DMViewWidth 14 

 DMViewHeight 15 

Existing QXDM views that demonstrate this format can be found in the QXDM HTML folder: 16 

 17 

<!doctype html public “-//w3c//dtd xhtml 1.0 strict//en” 18 

“http://www.w3.org/tr/xhtml1/dtd/xhtml1-strict.dtd”> 19 

<html> 20 

<head> 21 

  <meta name=“DMViewName” content=“Your HTML View Name” /> 22 

  <meta name=“DMViewWidth” content=“600” /> 23 

  <meta name=“DMViewHeight” content=“400” /> 24 

 25 

  <title>Your HTML View Name</title> 26 

  <link rel=“stylesheet” href=“QXDMStyle.css” /> 27 

</head> 28 

NOTE: A default cascading style sheet file (QXDMStyle.css) is installed in the QXDM HTML folder. 29 

This file controls the font faces, font sizes, table layout, and overall color scheme used by all 30 

native QXDM HTML displays. Although you can override these settings by editing the contents 31 

of this file (the discussion of which is beyond the scope of this document), the changes will be 32 

overwritten the next time QXDM is upgraded. 33 

Using the QXDM COM interface, you can write your own custom HTML views that process and 34 

display data received from the target. Refer to the QXDM HTML folder for various examples of 35 

HTML views. See Section 8.2 for a complete description of supported methods and properties. 36 
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4.3.1  Menu options 1 

Right-clicking within any HTML view brings up a context-sensitive menu, as illustrated in  2 

Figure 4-15. 3 

 4 

Figure 4-15  HTML view menu 5 

This menu allows you to change the zoom level of the view. The default zoom level is 100%. 6 

Decreasing the zoom level decreases the size of the view contents. Increasing the zoom level 7 

increases the size of the view contents. 8 
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4.4  Graph views 1 

Graph views exist for the technologies listed in Table 4-4. 2 

Table 4-4  Graph views 3 

View name Technology 

CDMA Temporal Analyzer 1X 
CDMA Finger Placement 1X 
CDMA Link Info - Forward 1X 
CDMA Link Info - Reverse 1X 
CDMA Power 1X 
CDMA Reverse Link 1X 
CDMA RLP Throughput 1X 
GSM GPRS Air Interface Summary GSM/GPRS 
GSM GPRS Tx Timing GSM/GPRS 
HDR Air Link Summary 1xEV-DO 
HDR Power 1xEV-DO 
HDR Rev A DRC-DSC-ARQ Buffer Metrics 1xEV-DO 
HDR Rev A Equalizer Metrics 1xEV-DO 
HDR Rev A Forward Link Packet Header Info 1xEV-DO 
HDR Rev A Forward Link User Packet Throughput 1xEV-DO 
HDR Rev A RAB Info 1xEV-DO 
HDR Rev A Reverse Link T2P Statistics 1xEV-DO 
HDR Rev A Reverse Link Gain Ratios 1xEV-DO 
HDR Rev A Reverse Link Packet Info 1xEV-DO 
HDR Rev A Reverse Link Packet Status 1xEV-DO 
HDR Rev A Reverse Link Throughput 1xEV-DO 
HDR Temporal Analyzer 1xEV-DO 
Task Profiling Common 
Qtv™ Audio Video Sync Common 
Qtv Buffer Occupancy Common 
Qtv Inter-Arrival Jitter Common 
Qtv Packets Lost Common 
Qtv Streaming RX Statistics Common 
UMTS Cell Reselection UMTS 
VoIP QDJ Parameters Common 
VoIP QDTX Parameters Common 
WCDMA Active Set PSC Strength WCDMA/HSDPA 
WCDMA BLER WCDMA 
WCDMA BLER Total WCDMA 
WCDMA Capacity/Quality Measurements WCDMA 
WCDMA CM GSM Measurement WCDMA 
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View name Technology 

WCDMA HSDPA Decoding Statistics WCDMA/HSDPA 
WCDMA HSDPA Link Statistics WCDMA/HSDPA 
WCDMA Pilot Scanner WCDMA 
WCDMA Power WCDMA 
WCDMA Power Control WCDMA 
WCDMA Radio Bearer Rate WCDMA 
WCDMA Temporal Analyzer WCDMA/HSDPA 

 
Graph views provide various configurations that are accessible from context menus. Clicking the 1 

right mouse button while over the view brings up the context menu, allowing various different 2 

configurations. 3 

 4 

Figure 4-16  Graph view context menus 5 

4.4.1  Clear 6 

Selecting Clear causes the history of all information plotted to be cleared. 7 
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4.4.2  Cursor 1 

Selecting Cursor causes a vertical line cursor to displayed or hidden on views that support this 2 

feature. Values for items over which the cursor is placed are displayed in the legend. The cursor 3 

can be dragged with the mouse to highlight points on the graph. 4 

4.4.3  Save Image 5 

Use Save Image to save the graph display contents to an image file in the BMP, JPG, or PNG 6 

image file formats. 7 

4.4.4  Auto-Scroll 8 

Selecting Auto-Scroll toggles automatic scrolling of the graph on views that support this feature. 9 

4.4.5  Auto-Slide 10 

Selecting Auto-Slide toggles automatic sliding of the graph (y axis) on views that support this 11 

feature. 12 

4.4.6  Axis Scroll Mode 13 

Selecting Axis Scroll Mode enables scrolling of the X or Y axis on views that support this 14 

feature. Holding down the left mouse button over the X or Y axis and dragging allows you 15 

to scroll. 16 

4.4.7  Axis Zoom Mode 17 

Selecting Axis Zoom Mode enables zooming of the X or Y axis on views that support this 18 

feature. Holding down the left mouse button over the X or Y axis and dragging allows you to 19 

control the range of viewable data in the window. 20 

4.4.8  Legend Visible 21 

Selecting Legend Visible toggles the display of the legend on views that support this feature. 22 

4.4.9  Range 23 

Use the Range option to select from a list of default zoom settings on views that support 24 

this feature. 25 
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4.4.10  View Y-Axis 1 

Use the View Y-Axis option to select from a list of available plots on views that support this 2 

feature. 3 

 4 

Figure 4-17  View Plots context menu option 5 

Plots generally correspond to individual Y-axes. 6 
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4.4.11  View Channel 1 

Use the View Channel option to select from a list of available channels on views that support this 2 

feature. 3 

 4 

Figure 4-18  View Channel context menu option 5 
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4.5  Other views 1 

4.5.1  Application Statistics 2 

The Application Statistics view provides detailed information relating to item traffic, item totals, 3 

and the Item Store. The display is broken into three sections (Figure 4-19). 4 

4.5.1.1  Communications port 5 

Communications statistics are accumulated since application startup. 6 

4.5.1.2  Item Totals 7 

Item Totals are for the current connection and all connections. Statistics are accumulated for 8 

items added to the Item Store, not items from a loaded ISF (File → Load Items). These totals are 9 

reset when the current Item Store is cleared or replaced. 10 

4.5.1.3  Item Store 11 

These statistics refer to the status of the current ISF, either loaded or temporary, and a history of 12 

the final statistics of each ISF file saved by QXDM (up to 100 of the last saved ISF files are 13 

displayed). 14 

 15 

Figure 4-19  Application Statistics 16 
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4.5.2  Dynamic Item view 1 

OTA log items, items described in either the QXDM database or a user database, or items 2 

registered for by currently loaded dynamic runtime parsing DLLs, can be viewed periodically 3 

using the Dynamic Item View. Right-click within the Dynamic Item View to configure what item 4 

to view periodically (Figure 4-20). 5 

 6 

Figure 4-20  Dynamic Item Config 7 

Use the dropdown shown above to set the frequency at which the selected item is refreshed. 8 

Frequency can be configured from once every 50 ms to once every 5 sec. Only one item can be 9 

selected per view. However, any number of Dynamic Item Views can be generated. 10 
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4.5.3  NV Browser 1 

NV items stored in the nonvolatile memory of the connected target can be viewed and modified 2 

using the NV Browser. 3 

 4 

Figure 4-21  NV Browser 5 

The Category Filter can be used to view just NV items belonging to a single category. 6 

To read an NV item, select the item to display the names of all the fields for that item and click 7 

the Read button to read the values from the phone. To write an NV item, select the item to display 8 

the names of all the item fields. To change the values, click the value in the Input column. After 9 

modifying the values, click the Write button to write the updated values back to the phone. 10 

NV items can be sorted by clicking the column header. Columns can be reordered by holding 11 

down the left mouse over a column header and dragging it to a new location. The left-most 12 

column can be searched by typing the name or number of interest. 13 

NOTE: Search typing is case-sensitive. The status of the NV read and write is given in the bottom left 14 

portion of the display. If you click Read or Write and see DIAG Error Received or NV Status 15 

Error Received, then the target was not able to handle the request. 16 
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4.5.3.1  Offline 1 

Use the Offline button to send the Mode Change Request Offline command to the phone before 2 

writing NV items that have mode-specific requirements. 3 

4.5.3.2  Reset 4 

Use the Reset button to send the Mode Change Request Reset command to the phone. This 5 

command when sent to a phone in Offline mode will result in the phone being recycled. 6 

4.5.3.3  Read 7 

Use the Read button to read the selected NV item from the NV memory of the connected target. 8 

4.5.3.4  Write 9 

Use the Write button to write the selected NV item to the NV memory of the connected target. 10 

4.5.4  Keypad 11 

The keypad provides a simple key display that simulates the handset keypad and display. It 12 

currently only supports a text-based display. 13 
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4.5.5  Memory Viewer <F4> 1 

This display allows you to view and edit memory locations inside the phone at runtime. Multiple 2 

memory locations can be viewed simultaneously by bringing up multiple instances of this view. 3 

By default, the left side of the view shows the memory address for each line, the middle shows 4 

the memory contents in hexadecimal, and the right side shows the ASCII character values of the 5 

memory. Memory that is readable is displayed as black characters and can be edited. If the 6 

memory is not readable, it will be grayed out. To edit memory, modify the memory contents by 7 

clicking in the region and typing new values. Memory values that have been modified for writes 8 

are displayed in red. 9 

NOTE: Any bytes displayed in red are buffered changes that have not yet been sent to the target, and the 10 

contents of memory on the target are not changed until Write is clicked. Note also that Write is 11 

disabled until there are buffered changes to write. 12 

 13 

Figure 4-22  Memory Viewer context menu 14 

4.5.5.1  Address 15 

To view other locations in memory, modify the address with a new address by selecting from the 16 

available addresses in the Address combo box or by typing a new address in the Address combo 17 

box and then pressing the Enter key. 18 

4.5.5.2  Rows 19 

The value specified in the Rows edit box determines the number of rows that are displayed. To 20 

change the value, select from the available list in the combo box. 21 
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Each row results in one diag request being sent to the target with a frequency of 1 sec, so the 1 

fewer the number of rows, the lesser the burden on diag. 2 

4.5.5.3  Write button 3 

The Write button will be grayed out if the memory address is unreadable. Clicking Write will 4 

result in a memory write request being sent to the phone. 5 

4.5.5.4  Context menu 6 

Use the context menu by clicking the right mouse button when held over the Memory Viewer. 7 

Control the appearance by hiding or displaying the addresses and ASCII characters and by 8 

controlling the number of bytes per line to display. Memory text can also be copied to the 9 

clipboard for pasting into another application. 10 

4.5.6  OS Core Dump 11 

By default, the OS Core Dump View is automatically launched when QXDM is started. This 12 

view registers interest in the OS Core Dump log. If a target that supports this log experiences 13 

failure, it attempts to send this log. Upon receipt, the log contents are displayed in this view. To 14 

disable OS Core Dump View registration, uncheck Auto-Launch Core Dump View from the 15 

Options menu. 16 

4.5.7  Task Profiling 17 

The Task Profiling view displays the results of the System-level Task and Per-task profiling logs. 18 

Per-task information is listed in the Task List pane and can be sorted in row order by clicking 19 

column headers. Tasks can also be plotted versus time in the Task Graph pane of this display. 20 

 21 

Figure 4-23  Task List pane 22 
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NOTE: Two Task Profiling views exist for dual-processor targets, Application Processing Unit (APU) 1 

and Modem Processing Unit (MPU). 2 

The Config button, at the bottom of the pane, allows you to configure which columns to display 3 

in the task list, which tasks to graph, and the interval at which task information is sent. 4 

 5 

Figure 4-24  Task Profiling Configuration 6 

The columns that can be displayed are described in Table 4-5. For additional information, refer to 7 

[Q1] for System-Level Task Profiling and Per-Task Profiling logs. 8 
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Table 4-5  Task Profiling Task Fields 1 

Task Description 

Delta CPU % Calculation is (Total Time – Old Total/Task Time – Old Task) converted to a percentage 
ID Unique identifier for the task 
Locked Interrupts locked state 
Max IPT Maximum interrupt time in ms that the task has kept interrupts locked 
Name Task name provided by the System Level Task Profiling log 
Old Task Previous update of Task Time 
Old Total Previous update of Total Time 
Priority The priority of the task 
Signal Mask Signal mask from the TCB that is set for the task 
Suspended Task suspended state 
Stack Pointer Stack pointer of the task 
Stack Limit Limit on the system stack for an ISR 
Stack Size Stack size in bytes of the task 
Task Time Total time task has been running since starting Task Profiling 
Total CPU % Percentage of time task has been running since starting Task Profiling 
Total Time Total time all tasks have been running since starting Task Profiling 
Wait Mask Signal mask of signals on which the task is currently waiting 
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4.5.8  Debug Trace View 1 

Debug Trace View enables you to view the trace dump files that are written to EFS on the phone 2 

as a result of abnormal target failure. The contents of the trace dump are retrieved when a trace 3 

dump file is selected and Start Transfer is clicked. 4 

 5 

Figure 4-25  Debug Trace View dump files 6 

NOTE: To facilitate analysis of the Debug Trace dump file, it is recommended that a new ISF file be 7 

started before each transfer and then saved when the transfer has completed. Additionally, all 8 

views except the Debug Trace View and Item View should be closed to ensure that the ISF file 9 

contains the traffic stored in the retrieved Debug Trace dump file and the traffic necessary to 10 

retrieve the contents of the Debug Trace file. 11 
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The results can be viewed in the Item View or a Filtered View that has been configured to receive 1 

Debug/Get Trace Item Response items. 2 

 3 

Figure 4-26  Debug Trace Dump retrieved items 4 
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4.5.9  CDMA Finger Placement 1 

The subplots in this view are described below. 2 

 3 

Figure 4-27  CDMA Finger Placement 4 

4.5.9.1  Finger statistics 5 

Finger statistics are displayed in this table. 6 

4.5.9.2  Delay (chips) 7 

This is the pilot PN of the finger, which the MSTR is tracking. The earliest arriving finger 8 

(smallest absolute position) is assumed to be the MSTR which is typically acceptable as the 9 

MSTR is currently not logged for CDMA. 10 

4.5.9.3  Current Ec/I0 (dB) 11 

This is the instantaneous Ec/I0 for each finger. For targets that support two antennae, three bars 12 

are displayed, Combined, Antenna 1, and Antenna 2. 13 
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4.5.9.4  Ec/I0 (dB) 1 

This is Ec/I0 for each finger, based on time of arrival. For targets that support two antennae, lines 2 

are drawn for Combined, Antenna 1, and Antenna 2 for each finger. 3 

The x-axis is time reported by the target, not generic time. This means that QXDM will ignore 4 

data from logs whose timestamp precedes the last timestamp plotted. 5 

4.5.10  Status 6 

The <F9> Status and Dynamic Status views display state information about the phone, such as 7 

Hardware Version, Build Version, System Determination, and Call Manager states. 8 

 9 
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5  Log View 1 

5.1  Log View 2 

The Log View is provided for backward compatibility. It is a Filtered View with limited 3 

functionality that is configured and behaves according to the legacy requirements described 4 

below. 5 

NOTE: The legacy Log View has limited functionality and is provided only for backward compatibility. 6 

The correct approach is to use Always-On logging behavior in conjunction with Filtered Views. 7 

 8 

See Section 3.1.10 for details on how to configure Always-On logging behavior. 9 

5.2  Log View Configuration 10 

All client and view registrations, including the selections made through Options→Log View 11 

Configuration, contribute to what ends up in the log file. After connecting to a device, Log View 12 

behavior is as follows: 13 

1. The Log View is created when the accelerator key, Alt + L, is pressed and is destroyed when 14 

ALT + L is pressed a second time. 15 

2. The first time ALT + L is pressed, the current Item Store is cleared. 16 

3. The second time ALT + L is pressed the current Item Store is saved to an ISF file with an 17 

automatically generated name consistent with the legacy DLF naming convention 18 

(MYYYYMMDD_HHMMSS.isf).  19 

4. The contents of the ISF will be all items received between steps 2 and 3, not just the items 20 

displayed in the Log View list. 21 

5. A new ISF log file is created on each phone (re)connection if Restart Log View Upon 22 

Disconnect from Options→Log View Configuration→Misc is checked. 23 

The Log View Configuration is provided for legacy reasons and does not utilize the advanced 24 

features of QXDM Always-On logging (see Section 2.5.1). The behavior described above is 25 

equivalent to configuring a generic Filtered View, using the File→New Items (Alt + I) to restart 26 

logging, and using the File→Save Items (CTRL + I) to save the log session. 27 

The following sections describe how to use the legacy Log View Configuration dialog. 28 
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5.2.1  Log Packets 1 

The number of logs displayed in the Log Mask dialog will vary depending on the number of logs 2 

supported by the connected FFA or SURF. 3 

 4 

Figure 5-1  Options→Log View Configuration→Log Packets 5 
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5.2.2  Message Packets 1 

The Message Packets tab allows you to configure the types of Debug Trace messages that are 2 

displayed by the Log View. 3 

 4 

Figure 5-2  Options→Log View Configuration→Message Packets 5 
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5.2.3  Event Reports 1 

The Event Reports tab allows you to control the events that are displayed by the Log View. 2 

NOTE: All events should be logged for maximum compatibility with some postprocessing tools. 3 

 4 

Figure 5-3  Options→Log View Configuration→Event Reports 5 
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5.2.4  Diagnostic Logs 1 

The Diagnostic Logs tab allows you to specify the diagnostic log items that are generated by the 2 

Log View. 3 

 4 

Figure 5-4  Options→Log View Configuration→Diagnostic Logs 5 

5.2.4.1  GSM NV Items 6 

The following GSM NV items are requested and logged when this option is selected: 7 

 GSM NV Test Code Version 8 

 GSM NV System Software Version 9 

 GSM NV RF Cal Version 10 

 GSM NV RF Cal Date 11 

 GSM NV RF Load Date 12 

 GSM NV RF Cal File 13 

 GSM NV RF Config Version 14 
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5.2.4.2  IS-2000 Items 1 

The following diagnostic packets are requested and logged every 500 ms when this is selected: 2 

 IS 2000 Status (periodic) 3 

 IS 2000 Standard Retrieve Parameters (periodic) 4 

 IS 2000 Extended Retrieve Parameters (periodic) 5 

5.2.5  Strings 6 

The Strings tab allows you to specify the string items that are displayed by the Log View. 7 

 8 

Figure 5-5  Options→Log View Configuration→Strings 9 
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5.2.6  Misc 1 

The Misc tab allows you to specify where log files generated by the operation of the legacy Log 2 

View are saved. The default folder is the QXDM ISF folder (typically located at  3 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\ISF). Checking Restart Log 4 

View Upon Disconnect results in a new log file each time QXDM is disconnected from a target 5 

while Log View is enabled. 6 

 7 

Figure 5-6  Options→Log View Configuration→Misc 8 

 9 
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6  Messages View 1 

6.1  Messages View 2 

Similar to Log View, the Messages View is a special case filtered view. For legacy reasons, the 3 

Messages View is still configured using the Message View Configuration dialog, accessible by 4 

selecting Options→Message View Configuration or by pressing CTRL + F5. 5 

Messages View behavior is: 6 

 Messages View shows only the traffic received during the life of the view. 7 

 Message View Configuration settings are communicated to the target when the Messages 8 

View is created. 9 

 Message View Configuration settings are removed from the target when the view is 10 

destroyed. 11 

NOTE: The Messages View has limited functionality and is provided only for backward compatibility. 12 

The correct approach is to use Filtered Views and configuration (.DMC) files. 13 

6.2  Message View Configuration 14 

The configuration dialog consists of five tabs, Message Packets, Log Packets, Log Packets 15 

(OTA), Event Reports, and Strings. 16 
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6.2.1  Log Packets 1 

The Log Packets tab is shown in Figure 6-1. 2 

 3 

Figure 6-1  Options→Message View Configuration→Log Packets 4 
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6.2.2  Log Packets (OTA) 1 

The Log Packets (OTA) tab allows you to select the OTA Log message types. 2 

 3 

Figure 6-2  Options→Message View Configuration→Log Packets (OTA) 4 
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6.2.3  Message Packets 1 

The Message Packets tab allows you to set the debug trace message types that the Messages View 2 

will accept. 3 

 4 

Figure 6-3  Options→Message View Configuration→Message Packets 5 
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6.2.4  Event Reports 1 

The Event Reports tab allows you to control the events that the Messages View will accept. 2 

 3 

Figure 6-4  Options→Message View Configuration→Event Reports 4 
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6.2.5  Strings 1 

The Strings tab allows you to control the types of string items that the Messages View will 2 

accept. 3 

 4 

Figure 6-5  Options→Message View Configuration→String 5 

 6 
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7  Command Prompt Interface 1 

QXDM provides an interface that allows you to enter and send commands manually or have them 2 

sent from a prepared script file (.scr extension). 3 

The interface is limited in that command status and response data can only be evaluated visually. 4 

QXDM COM automation (Chapter 8) does not have this limitation and is the preferred solution to 5 

write fully automated test cases. 6 

7.1  QXDM properties 7 

NOTE: QXDM property definitions are not sufficient to describe many diagnostic packets and have been 8 

migrated to the QXDM database. User-defined property definitions will also need to be migrated 9 

to user database definitions. Use the Database Editor (included with QXDM) to describe user-10 

defined items (see [Q6] for details). 11 

Table 7-1 lists the replacements that should be used instead of the obsolete property interface 12 

commands. The database command replacements are described in Section 7.2. 13 

Table 7-1  Property command replacements 14 

Property command Database command replacement 

get_property <property name> 
<optional field> 

RequestItem <item name> <optional fields> 
RequestNVItemRead <item name> <optional fields> 

put_property <property name> 
<fields> 

RequestItem <item name> <fields> 
RequestNVItemWrite <item name> <fields> 

print_property <property 
name> 

Click on an item in the Item Tester Application (Figure 7-1)  

list_properties Use the Item Tester Application (accessible from the Tools menu,  
Figure 3-18) 

nv_read <NV property item> RequestNVItemRead <item name> <optional fields> 
nv_write <NV property item> RequestNVItemWrite <item name> <fields> 
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7.2  Command functions 1 

NOTE: The Script Help page documents all supported command prompt functions. It is available in the 2 

View combo box from the View Bar (Figure 4-1). This view also provides documentation for the 3 

legacy script commands that are part of the original DOS DM scripting interface. 4 

Some script commands direct packets to the test phone, while others affect only QXDM 5 

operations. Command output is displayed in the Command Output window and can also be 6 

viewed from the Item View and any Filtered View that has registered interest in automation string 7 

items. 8 

Several functions are provided to support waiting for, requesting, and parsing of any item that is 9 

described in the QXDM database. Additional support is provided in the Item Tester application 10 

that provides formatting examples using these commands for all items described in the database. 11 

The Item Tester is accessible from the QXDM Tools menu. 12 

 13 

Figure 7-1  Tester QXDM Command Example 14 

 15 

Figure 7-2  Copy from Item Tester application to QXDM command 16 

NOTE: Functions that wait for responses use the Script Commands timeout option configurable through 17 

the menu item Options→Communications→Script Commands. 18 
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7.2.1  CWait 1 

This halts scripting for a specified amount of time. 2 

 
Parameter Description 

Time Time in centiseconds to wait 

Example 3 

Wait 500 4 

Halt scripting for 5 sec 5 

7.2.2  Echo 6 

Adds a text string to the DM Item Store.  7 

 
Parameter Description 

Text Adds the provided string to the DM Item Store with the Automation type; the string will 
appear in a list-based view registered for this type (including the Command Output view) 

Example 8 

Echo “Test completed” 9 

7.2.3  Logging 10 

NOTE: This command is provided only for legacy reasons and does not utilize the advanced logging 11 

features of QXDM Always-On logging (Section 2.5.1). 12 

This brings up or closes the Log View. 13 

 
Parameter Description 

State State can be either On or Off: 
 On – Brings up the Log View, if not already active 
 Off – Tears down the Log View, if active 

Example 14 

Logging On 15 
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7.2.4  LogMask 1 

NOTE: This command is provided only for legacy reasons and does not utilize the advanced logging 2 

features of QXDM Always-On logging (see Section 2.5.1). 3 

LogMask sets the Common portion of the Log View log configuration mask. Log masks for other 4 

equipment are not supported using this command. 5 

 
Parameter Description 

Mask Mask is the desired log mask in the format of Hex Value portion of the Log Config dialog 

Example 6 

LogMask 99ff 7 

7.2.5  Mode 8 

This requests that the target perform a mode change. 9 

 10 

Parameter Description 

Mode Mode can be one of the following string values: 
 FTM – Change to Factory Test mode 
 LPM – Change to Low Power mode 
 Offline-A – Change to Offline Analog mode 
 Offline-D – Change to Offline Digital mode 
 Online – Change to Online Digital mode 
 Reset – Reset the target (may require Phone Offline mode) 

Example 11 

Mode Reset – Requests the target reset 12 

7.2.6  Pause 13 

This halts processing of a legacy script (.scr) processing. The Space Bar must be pressed in the 14 

Command edit box to continue processing. 15 

Example 16 

Pause 17 
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7.2.7  RequestItem 1 

RequestItem allows you to schedule a request to be sent to the phone. The request itself is built 2 

according to a description entered into the QXDM database or the user database diag entity table. 3 

RequestItem waits for a response and, if received, parses it according to the default description in 4 

the QXDM database or the user database (if a description exists). 5 

 
Parameter Description 

Name Name of diag entity to request (entity must be either a diag request or subsystem dispatch 
request) 

Fields List of space-separated fields used to build the request 

Example 6 

RequestItem “Version Number Request” 7 

RequestItem “Extensible Parameter Retrieval Request” 1 1 100 8 

7.2.8  RequestItemFile 9 

RequestItemFile allows one to schedule a request to be sent to the phone using a file that contains 10 

input field values. The request itself is built according to a description entered into the QXDM 11 

database or a user database. RequestItemFile waits for a response and if received, parses it 12 

according to the default description in the QXDM database or a user database (if such a 13 

description exists). 14 

 
Parameter Description 

Name Name of diag entity to request (entity must be either a diag request or subsystem 
dispatch request) 

FileName Name of a file containing field values used to build the request. This argument can be 
omitted if the request does not require field values. The file should contain one line for 
each input field of field, value pairs, separated by the caret (^) character. For example: 
Number Of Digits^10 
Digits^2144951009 
Service Option^17 
Note: QXDM searches for FileName based on the following search criteria: 
 Search using the file as-is 
 Search using the installation default QXDM data path 

(C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM) 
 Search using the Alternate Script Path (Options → Settings) 

Examples 15 

RequestItemFile “Mode Change Request” “ModeOnlineDigital.txt” 16 

RequestItemFile “Call Origination Request” “CallOriginate.txt” 17 
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7.2.9  RequestNamedItem 1 

RequestNamedItem allows you to schedule a request to be sent to the phone. It is similar to 2 

RequestItem with the exception that the named response must also be specified for QXDM to use 3 

in parsing the response. RequestNamedItem waits for the response and, if received, parses it 4 

according to the description in the QXDM database or the user database diag entity tables.  5 

 
Parameter Description 

ResponseName Name of diag entity to use for parsing the response 
RequestName Name of diag entity to request (entity must be either a diag request or subsystem 

dispatch request) 
Fields Field values used to build the request 

Examples 6 

RequestNamedItem “Version Number Response” “Version Number Request” 7 

RequestNamedItem “My Response” “Extensible Parameter Retrieval Request” 1 1 8 

125 9 

7.2.10  RequestNamedItemFile 10 

RequestNamedItemFile allows one to schedule a request to be sent to the phone using a file that 11 

contains input field values. The request itself is built according to a description entered into the 12 

QXDM database or a user database. RequestNamedItemFile waits for a response and if received, 13 

parses it according to the description matching the provided diag entity name. 14 

 
Parameter Description 

ResponseName Name of the diag entity used to parse the responses (if received) 
RequestName Name of the diag entity to request (entity must be either a diag request or subsystem 

dispatch request) 
FileName Name of a file containing field values used to build the request. This argument can be 

omitted if the request does not require field values. The file should contain one line 
for each input field of field, value pairs, separated by the caret (^) character. For 
example: 
Number Of Digits^10 
Digits^2144951009 
Service Option^17 
Note: QXDM searches for “FileName” based on the following search criteria: 
 Search using the file as-is 
 Search using the QXDM installation default data path 

(C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM) 
 Search using the Alternate Script Path (Options → Settings) 

Examples 15 

 RequestItemFile Mode Change Response Mode Change Request OnlineD.txt 16 

 Builds and sends a Mode Change Request with field values contained in 17 

ModeOnlineDigital.txt to the target and waits for and parses the response using the database 18 

description for Mode Change Response. 19 

 RequestItemFile Call Origination Response Call Origination Request Call.txt 20 
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 Builds and sends a Call Origination Request to the target with field values contained in the 1 

file CallOriginate.txt and waits for and parses the response using the database description for 2 

Call Origination Response. 3 

7.2.11  RequestNVItemRead 4 

RequestNVItemRead allows you to schedule one NV read request to be sent to the phone. The 5 

request itself is built according to a description entered into the QXDM database or the user 6 

database diag entity table. RequestNVItemRead waits for the response and, if received, parses it 7 

according to the description in the QXDM database or the user database diag entity tables. 8 

 
Parameter Description 

NVItemName Name of the NV item entity to read 
Fields Field values used to build the request 

Example 9 

RequestNVItemRead “banner” 10 

RequestNVItemRead “air_timer” 1 11 

7.2.12  RequestNVItemWrite 12 

RequestNVItemWrite allows you to schedule one NV write request to be sent to the phone. The 13 

request itself is built according to a description entered into the QXDM database or the user 14 

database diag entity table. RequestNVItemWrite waits for the response and, if received, parses it 15 

according to the description in the QXDM database or the user database diag entity tables. 16 

 
Parameter Description 

NVItemName Name of the NV item entity to write 
Fields Field values used to build the request 

Example 17 

RequestNVItemWrite “banner” “My MSM7500” 18 

7.2.13  RequestNVItemIDRead 19 

RequestNVItemIDRead allows one to schedule one NV read request to be sent to the phone. The 20 

request itself is built according to arguments entered as raw bytes. RequestNVItemIDRead waits 21 

for the response, reporting result status. 22 

 
Parameter Description 

ItemNumber Item number of the NV diag entity to be read 
RawBytes Optional list of space-separated byte values used to build the NV item being read 

Example 23 

RequestNVItemIDRead 71 24 

RequestNVItemIDRead 10 0 0 0 25 
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7.2.14  RequestNVItemIDWrite 1 

RequestNVItemIDWrite allows one to schedule one NV write request to be sent to the phone. 2 

The request itself is built according to arguments entered as raw bytes. RequestNVItemIDWrite 3 

waits for the response, reporting result status. 4 

 
Parameter Description 

ItemNumber Item number of the NV diag entity to be written 
RawBytes Optional list of space-separated byte values used to build the NV item being written 

Example 5 

RequestNVItemIDWrite 71 77 83 77 32 54 53 53 48 6 

RequestNVItemIDWrite 10 0 0 0 7 

7.2.15  Run 8 

This transfers command processing to a legacy (.scr) script file. 9 

 
Parameter Description 

FileName FileName is the name of the legacy *.scr file to process. 
Note: QXDM searches for FileName based on the following search criteria: 
 Search using the file as-is 
 Search using the QXDM installation default data path 

(C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM) 
 Search using the Alternate Script Path (Options→Settings) 

Example 10 

Run “Test Case 20.scr” 11 

Run “C:\My .SCR tests\Test Case 20.scr” 12 

7.2.16  SendRawRequest 13 

SendRawRequest allows one to schedule one diag request to be sent to the phone. The request 14 

itself is built according to arguments entered as raw bytes. SendRawRequest waits for the 15 

response, reporting result status. 16 

 
Parameter Description 

RawBytes List of space-separated byte values used to build the diag request being sent 

Example 17 

SendRawRequest 39 71 0 77 83 77 32 54 53 53 48 18 

SendRawRequest 0 19 
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7.2.17  Wait 1 

This halts scripting for a specified amount of time. 2 

 
Parameter Description 

Time Time in seconds to wait 

Example 3 

Wait 10 4 

7.2.18  WaitForItem 5 

WaitForItem allows you to register interest in and wait for an item. The item name is the diag 6 

entity name in the QXDM database or the user database diag entity table. Requests for 7 

asynchronous commands (logs, events, and debug messages) may result in a registration being 8 

sent to the phone. WaitForItem can also be used to wait for synchronous requests or responses. 9 

At the conclusion of the command, the registration is revoked. 10 

NOTE: WaitForItem only waits for a response. It does not make a request. Use RequestItem (see 11 

Section 7.2.7) or RequestNamedItem (see Section 7.2.9) to request an item and wait for the 12 

response. 13 

 
Parameter Description 

ItemName Name of diag entity to request  

Example 14 

WaitForItem EVENT_CALL_CONTROL_TERMINATED 15 

WaitForItem “Searcher and Finger” 16 

WaitForItem “Get IS-2000 Status Response” 17 

 18 
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8  COM Automation Interfaces 1 

The QXDM application is a Windows 2000/Windows XP (and later) application that utilizes the 2 

existing diag serial interface via the Atlas/QPST phone server in order to establish a connection to 3 

a phone target. Once a connection is established, QXDM allows the user to manipulate and 4 

monitor the phone target by ultimately sending and receiving diag traffic to and from the target. 5 

QXDM itself is built upon the DM Core Framework, a library of objects and methods that 6 

encompasses all nonuser interface-related functionality implemented by QXDM. This includes 7 

but is not limited to target connection management, target data partitioning, target data 8 

representation, and data storage and nonsequential data access. 9 

To support extensibility and rapid prototyping, QXDM itself exports a subset of the DM Core 10 

Framework functionality through a set of COM interfaces. These interfaces allow QXDM to 11 

support scripting through any COM-compliant scripting language, e.g., VBScript, JScript, and 12 

Perl. Additionally, a large subset of these interfaces is exposed through HTML-based QXDM 13 

views. Each view combines the capabilities of the Microsoft Internet Explorer control, hosted in a 14 

QXDM window, with the rich QXDM COM interface capabilities, allowing both the QXDM 15 

team itself and QXDM users to create custom views. 16 

The QXDM COM interfaces are roughly divided into five modules, each described in the 17 

following sections: 18 

 QXDM – The QXDM COM automation interface that existed and shipped in QXDM 19 

versions prior to 03.05.50; although these interfaces are still part of the QXDM code base, it 20 

is intended that support for some of the interfaces will be phased out over time 21 

 Client – Provides a means to partition QXDM items (data obtained from the target and 22 

internal QXDM processing) into unique collections; also provides direct access to 23 

QXDM items 24 

 Client Config – Provides a means to configure the particular types of items in which a 25 

QXDM interface client is interested; i.e., it defines the partition a client represents 26 

 Item – Interface to a particular item being managed by QXDM 27 

 Field – Provides access to the QXDM database parsed fields of a particular item 28 

NOTE: Numerous automation sample scripts (written in both Perl and JScript) can be found under the 29 

Automation Samples folder in the “QXDM Data” folder described in Section 2.2 (which is 30 

typically located in 31 

C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\Automation Samples). 32 
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8.1  QXDM Interface (IQXDM) 1 

This section describes the legacy QXDM COM interface (IQXDM). 2 

8.1.1  AppVersion 3 

The AppVersion property returns the version of QXDM. 4 

A BSTR value is returned. 5 

8.1.2  ClearViewItems 6 

The ClearViewItems() function clears all items in the specified view. 7 

 
Parameter Type Description 

Display Name BSTR Name of display to clear; the name is interpreted as: 
 Item view – Item Store view 
 Messages view – Messages view 
 All others – Tagged filtered view name 

 
The function returns a VARIANT_BOOL response: 8 

 FALSE – Request was not received (e.g., view was not found) 9 

 TRUE – Request was successfully received 10 

8.1.3  COMPort 11 

The COMPort property can be used to view the currently selected COM port or to change to 12 

another COM port for which QXDM will attempt to connect to a phone. 13 

A SHORT value is returned: 14 

 -1 – Error occurred 15 

 0 – Disconnect state 16 

 1…n – COM port selected 17 
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8.1.4  CopyViewItems 1 

The CopyViewItems() function copies all items to an Item Store Format file. 2 

 
Parameter Type Description 

Display Name BSTR Name of display to copy; the name is interpreted as: 
 Item view – Item Store view 
 Messages view – Messages view 
 Log view – Log view 
 All others – Tagged filtered view name 

Destination File BSTR Name of the destination Item Store Format file 
 

The function returns a VARIANT_BOOL response: 3 

 FALSE – Request was not received (e.g., view was not found) 4 

 TRUE – Request was successfully received 5 

8.1.5  CloseView 6 

The CloseView() function allows you to close an existing QXDM view. 7 

 
Parameter Type Description 

pViewName BSTR Name of QXDM view to close 
pViewTag BSTR Window tag for views that support multiple instances or empty  

string (“”) 
 

The function returns a VARIANT_BOOL that indicates whether a view was closed. 8 

NOTE: Due to the unique operation of the QXDM log view, this function does not apply to the QXDM 9 

log view. 10 

8.1.6  CreateView 11 

The CreateView() function allows you to bring up a QXDM view. 12 

 
Parameter Type Description 

pViewName BSTR Name of QXDM view to bring up 
pViewTag BSTR Window tag for views that support multiple instances or empty string 

(““) 
 

The function returns a VARIANT_BOOL that indicates whether a view was created. If a view of 13 

the same name is already present and that view does not support multiple instances, the existing 14 

view will be brought to the forefront. In this case, success is returned. 15 

NOTE: Due to the unique operation of the QXDM log view, this function does not apply to the QXDM 16 

log view. 17 
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8.1.7  DipSwitchMask 1 

The DipSwitchMask() property is used to set DIP switch settings. 2 

 
Parameter Type Description 

DIP switch value SHORT DIP switch values to set 
 

The function returns no value. 3 

8.1.8  ExportViewText 4 

The ExportViewText() function exports all items to a text file. 5 

 
Parameter Type Description 

Display Name BSTR Name of display to export; the name is interpreted as: 
 Item view – Item Store view 
 Messages view – Messages view 
 Log view – Log view 
 All others – Tagged filtered view name 

Destination File BSTR Name of the destination text file 
 

The function returns a VARIANT_BOOL response: 6 

 FALSE – Request was not received (e.g., view was not found) 7 

 TRUE – Request was successfully received 8 

8.1.9  GetIQXDM2 9 

The GetIQXDM2() function allows you to obtain an interface pointer to the QXDM client 10 

interface model (IQXDM2) as discussed in Section 8.2. The command takes no arguments and 11 

returns an IDispatch interface poin2)ter. 12 

8.1.10  GPSPort 13 

The GPSPort property can be used to view the currently selected COM port or to change to 14 

another COM port for which QXDM will attempt to connect to a GPS receiver. 15 

A SHORT value is returned: 16 

 -1 – Error occurred 17 

 0 – Disconnect state 18 

 1…n – COM port selected 19 

8.1.11  IsPhoneConnected 20 

The IsPhoneConnected property returns 1 if QXDM is in the phone Connected state and 0 21 

otherwise. Use GetServerState (Section 8.2.3) to determine what Nonconnected state QXDM is in. 22 

A LONG value is returned. 23 
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8.1.12  LoadConfig 1 

The LoadConfig() function loads a configuration file (.DMC).  2 

 
Parameter Type Description 

Config File BSTR Configuration file (see Section 3.1.4 for details) 
 

The function returns no response. 3 

8.1.13  LoadItemStore 4 

The LoadItemStore() function allows you to load an Item Store Format (*.ISF) file into QXDM.  5 

 
Parameter Type Description 

pFileName BSTR Fully qualified path to Item Store Format file 
 

The function returns a VARIANT_BOOL that indicates whether the Item Store Format file was 6 

loaded. 7 

NOTE: An ISF can be loaded into QXDM only when QXDM is in the Disconnected state. 8 

8.1.14  LogMask 9 

The LogMask property is enabled for legacy reasons only. The LogMask property returns the log 10 

mask that is configured for equipment ID 1 logging using the Log View. 11 

A BSTR value is returned in the format of the Log View Configuration dialog. 12 

8.1.15  LogMaskOff 13 

The LogMaskOff() function turns off a log item for which the Log View is registered. 14 

 
Parameter Type Description 

Log SHORT Log ID or log code 
Equipment ID SHORT Equipment ID 

 
The function returns no response. 15 

8.1.16  LogMaskOn 16 

The LogMaskOn() function turns on a log item for which the Log View is registered. 17 

 
Parameter Type Description 

Log ID SHORT Log ID or log code 
Equipment ID SHORT Equipment ID 

 
The function returns no response. 18 
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8.1.17  OfflineDigital 1 

The OfflineDigital() function attempts to set the phone to the Offline-Digital state. 2 

The function returns a LONG value: 3 

 0 – Failure to set the phone to Offline-Digital state 4 

 1 – Successfully set the phone to Offline-Digital state 5 

8.1.18  ResetPhone 6 

The ResetPhone() function resets the phone. 7 

The function returns a LONG value: 8 

 0 – Failure to reset the phone  9 

 1 – Successfully reset the phone 10 

8.1.19  SaveConfig 11 

The SaveConfig() function saves a configuration file (.DMC). 12 

 
Parameter Type Description 

Config File BSTR Configuration file (see Section 3.1.5 for details) 
 

The function returns no response. 13 

8.1.20  SendDmIcdPacket 14 

The SendDmIcdPacket() function is deprecated. Use SendDmIcdPacketEx instead (see 15 

Section 8.1.21). 16 

8.1.21  SendDmIcdPacketEx 17 

The SendDmIcdPacketEx() function sends a DM request/response packet to the target. 18 

 
Parameter Type Description 

Packet VARIANT Safe array of bytes to send to the target 
Timeout LONG Timeout value for the request 

 
The function returns a VARIANT that contains the response from the target. 19 
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8.1.22  SendScript 1 

The SendScript() function sends a command to QXDM to be executed on the QXDM command 2 

line.  3 

 
Parameter Type Description 

Command BSTR Command string to execute 
 

The function returns no value. 4 

8.1.23  SetCDMAProtocolRevision 5 

The SetCDMAProtocolRevision() function allows you to set the CDMA protocol revision that is 6 

used when parsing CDMA Over-the-Air (OTA) log items. 7 

 
Parameter Type Description 

rev ULONG Desired CDMA protocol revision; possible values are: 
 0 – IS-95A 
 1 – TBD 
 2 – TBD 
 3 – TBD 
 4 – IS-95B 
 5 – TBD 
 6 – IS-2000 Rev 0 
 7 – IS-2000 Rev A 
 8 – IS-2000 Rev B 
 9 – IS-2000 Rev C 
 10 – IS-2000 Rev C 
 11 – IS-2000 Rev D 
 0x7FFFFFFF – Automatic 

 
The function returns no value. 8 
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8.1.24  SetWCDMAProtocolRevision 1 

The SetWCDMAProtocolRevision() function allows you to set the WCDMA protocol revision 2 

that is used when parsing WCDMA OTA log items. 3 

 
Parameter Type Description 

rev ULONG Desired WCDMA protocol revision; possible values are: 
 0 – 1999 (RRC 25.331 V3.5.0 – 12/00 3GPP) 
 1 – 6/01 (RRC 25.331 V3.7.0) 
 2 – 3/02 (RRC 25.331 V3.A.0) 
 3 – 3/04 (RRC 25.331 V3.I.0) 
 4 – 6/04 (RRC 25.331 V5.9.0) 
 5 – 12/05 (RRC 25.331 V6.8.0) 
 6 – 3/06 (RRC 25.331 V6.9.0) 
 7 – 6/06 (RRC 25.331 V6.A.0) 
 8 – 9/06 (RRC 25.331 V6.B.0) 
 0x7FFFFFFF – Automatic 

 
The function returns no value. 4 

8.1.25  SaveItemStore 5 

The SaveItemStore() function allows you to save a temporary Item Store Format file (*.ISF). This 6 

function is subject to the same conditions as Save Items (see Figure 3-7).  7 

 
Parameter Type Description 

pFileName BSTR Fully qualified file name of the Item Store Format file to be saved 
 

The function returns no value. 8 

NOTE: When QXDM is run, an ISF is created using a temporary name in the QXDM ISF folder 9 

(typically located at C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\ISF). 10 

This is then used as the current ISF. If the user (either through the interaction with the QXDM 11 

GUI or through the QXDM automation interface) initiates the loading of an existing ISF, the 12 

current ISF may be saved if it is nonempty and the user has enabled Item Store saving. In this 13 

case, the filename specified by SaveItemStore() is used to rename and move the current ISF. This 14 

process does not apply when the user has already loaded an existing ISF. 15 

8.1.26  SetLoggingOn 16 

The SetLoggingOn() function is deprecated. Use SetLoggingOnEx instead (see Section 8.1.27). 17 
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8.1.27  SetLoggingOnEx 1 

The SetLoggingOnEx() function sets the log mask to the mask provided for the specified 2 

equipment ID and switches logging on. 3 

 
Parameter Type Description 

Log Mask BSTR Hexadecimal log mask in the Log View Configuration dialog 
format 

Equipment ID SHORT Equipment ID intended for log mask 
 

The function returns no value. 4 

8.1.28  SetLoggingOff 5 

The SetLoggingOff() function sets the log filename to the name provided as a parameter and 6 

switches logging off.  7 

 
Parameter Type Description 

Log filename BSTR Filename to use for logging 
 

The function returns no value. 8 

8.1.29  SetVendorDatabase 9 

The SetVendorDatabase() function allows you to load a new vendor-specific database. A 10 

vendor-specific database is used when parsing items specific to a particular handset vendor 11 

(currently only NV items). A vendor-specific database also contains mobile model names. 12 

 
Parameter Type Description 

pDatabasePath BSTR Fully qualified folder name containing the vendor database 
 

The function returns a VARIANT_BOOL indicating success/failure. 13 

8.1.30  QuitApplication 14 

The QuitApplication() function causes the QXDM application to terminate. 15 

The function returns no value. 16 

8.1.31  QXDMTextOut 17 

The QXDMTextOut() function adds a string to the Item Store. 18 

 
Parameter Type  Description 

Text BSTR String to display in views that are registered to receive 
Automation strings 

 
The function returns no value. 19 
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8.1.32  Visible 1 

The Visible property can be used to get the Visible state of QXDM or to show or hide the QXDM 2 

server application. 3 

 
Parameter Type Description 

Visible value VARIANT_BOOL QXDM server application Visible state 
 

The function returns a VARIANT_BOOL. 4 

8.1.33  WaitEvent 5 

The WaitEvent() function waits for an event from the target. It returns the event if received within 6 

the timeout specified; otherwise, a VARIANT of type VT_EMPTY is returned. 7 

 
Parameter Type Description 

Event ID LONG Event ID for which to wait  
Timeout LONG Timeout value to wait 

 
The function returns a VARIANT. 8 

8.1.34  SetParsingOrder 9 

  NOTE: This section was added to this document revision. 
10 

The SetParsingOrder() function sets the hierarchy for the parsing source. 11 

 
Parameter Type Description 

Order ULONG Desired order: 
 0 – Prefer parsing DLLs (order set elsewhere), then default 

DB 
 1 – Prefer parsing DLLs (order set elsewhere), user DB, then 

default DB 
 2 – Prefer default DB, then last user DB 
 3 – Prefer last user DB, then default DB 
 4 – Prefer APEX/QCAT, parsing DLLs (order set elsewhere), 

then default DB 
 5 – Prefer APEX/QCAT, parsing DLLs (order set elsewhere), 

then user DB 
 6 – Prefer APEX/QCAT, default DB, then last user DB 
 7 – Prefer APEX/QCAT, last user DB, then default DB 

 

8.2  Client Interface (IQXDM2) 12 

This section describes the QXDM client interface (IQXDM2). 13 
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8.2.1  RequestItem 1 

The RequestItem() function allows one or more requests to be scheduled for transmission to the 2 

target. The request itself is built according to a description entered into the QXDM database diag 3 

entity table.  4 

 
Parameter Type Description 

pRequestName BSTR Name of diag entity (either a diag request or subsystem 
dispatch request) 

pFields BSTR Fields used to build the request 
bValuesOnly VARIANT_BOOL Does the pFields argument represent a string containing only 

the field values, or does it represent a fully qualified filename 
representing a text file containing the full field names and their 
values (such as generated by the QXDM Item Tester 
application)? 

timeout ULONG Base timeout value in ms for request 
requestCount ULONG Number of requests to schedule (must be at least one) 
frequency ULONG If the requestCount argument is greater than one, this 

represents the amount of time (in ms) between successive 
requests. 

 
The function returns a unique request ID. Upon error, 0 is returned. 5 

NOTE: If bValuesOnly is VARIANT_TRUE, then the format of pFields is a space-delimited string of 6 

field values where string field values are enclosed in quotes, i.e., 0xFF 100 “A String.” 7 

 8 

This example specifies that the first field of the request has the value 0xFF, the second field has 9 

the value 100, and the last field for the request has the value A String. For fields that are 10 

enumerations, the raw value must be provided, i.e., the integral value. 11 

 12 

If bValuesOnly is VARIANT_FALSE, then pFields is the fully qualified name of the file that 13 

gives the fields and their values. The format of the file is one field/value pair per line where the 14 

field is separated from the value by the ^ character. For an example, see the QXDM Item Tester 15 

application. 16 

 17 

The timeout argument is dependent on the QPST Server. Current builds of QPST Server 18 

automatically retry each request up to three times in the case of a timeout while waiting for the 19 

response. Thus, the total timeout value is the argument value times three. Due to the real-time 20 

nature of QXDM, the maximum value for timeout is 2000 ms. 21 

 22 

If the requestCount argument value is greater than one, then the request is considered to be 23 

repetitive. The first request will be scheduled to go out immediately. Subject to target latencies 24 

and the number of requests in the diag server queue, the next instance of this request will be sent 25 

out frequency ms after the response to the first request is received (or a timeout occurs). Due to 26 

the real-time nature of QXDM, the minimum value for the request frequency is currently 10 ms. 27 

A value of 0xFFFFFFFF for the request count indicates that the caller wants requests to be 28 

scheduled indefinitely. 29 
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8.2.2  RemoveRequest 1 

The RemoveRequest() function allows you to cancel an existing request. 2 

 
Parameter Type Description 

requestID ULONG Unique request ID 
 

The function returns a VARIANT_BOOL indicating success/failure. 3 

8.2.3  GetServerState 4 

The GetServerState() function allows you to retrieve the state of the QXDM diag server. This is 5 

an extension of the previous IsConnected() function that takes no arguments and returns a 6 

ULONG. The ULONG return value is one of the values listed below.  7 

 
Value Description 

0 Target is disconnected. This is the initial state, which indicates that QXDM is not 
connected to a target. 

1 QXDM is about to be connected to a target, QXDM has connected to a target via QPST 
Server, but all up-front initialization has not yet occurred. 

2 Target has been verified, QXDM is connected to a target and has successfully completed 
all up-front initialization. This currently consists of querying the target for version 
information, supported log items, and supported message levels, etc. 

3 QXDM is about to disconnect from a target. Commands must be sent to the target to get 
it into a desired state. Once those commands are sent, QXDM will transition to the 
Disconnected state. 

4 In Playback mode, QXDM is not physically connected to a target. Rather, QXDM is 
operating from a file generated by a previous target connection. Async diag data is read 
from that file and distributed to interested parties as if connected to a live target. Note 
that playback can be reached only from the Disconnected state. 

0xFFFFFFFF Error 

8.2.4  GetItemCount 8 

The GetItemCount() function allows you to retrieve the number of items in the current QXDM 9 

Item Store. The function takes no arguments and returns a ULONG. The ULONG return value 10 

represents the total number of items in the Item Store (upon error 0 is returned). 11 

8.2.5  GetItem 12 

The GetItem() function allows you to retrieve a particular item from the current QXDM Item 13 

Store. 14 

 
Parameter Type Description 

index ULONG Index of item to retrieve (the Item Store is indexed 0 to the 
number of items returned by GetItemCount() – 1) 

 
The function returns an interface pointer to the QXDM item interface model (IColorItem) as 15 

discussed in a subsequent section. 16 
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8.2.6  RegisterClient 1 

The RegisterClient() function allows you to register as a client with QXDM. A client represents a 2 

subset of the QXDM Item Store whose contents are generally tailored to the needs of a particular 3 

display or script.  4 

 
Parameter Type Description 

pClientName BSTR Name of client or empty string (““) 
bFilteredView VARIANT_BOOL Bring up a QXDM filtered view tied to the client. If set to 

VARIANT_TRUE, a valid client name is required to be provided. 
As the filtered view is tied to the client, it will be restricted in 
functionality. The primary usage is intended to be for debugging 
user views and scripts. 

 
The function returns a ULONG that represents the unique client identifier (handle). It is used in 5 

all subsequent client calls. Upon error 0xFFFFFFFF is returned. 6 

8.2.7  RegisterQueueClient 7 

The RegisterQueueClient() function allows you to register as a client with QXDM. A client 8 

represents a subset of the QXDM Item Store whose contents are generally tailored to the needs of 9 

a particular display or script. This version differs from RegisterClient() in that the client that is 10 

created internal to QXDM is of fixed size, i.e., only the last N items are available at any point in 11 

time. This allows for a more efficient representation that utilizes fewer system resources and 12 

supports expedited processing. 13 

 
Parameter Type Description 

queueSize ULONG Size of queue (the value must be 256, 512, 1024, 2048, 4096, 
16384, or 65536) 

 
The function returns a ULONG that represents the unique client identifier (handle). It is used in 14 

all subsequent client calls. Upon error 0xFFFFFFFF is returned. 15 

8.2.8  UnregisterClient 16 

The UnregisterClient() function allows you to unregister an existing client. 17 

 
Parameter Type Description 

hClient ULONG Unique handle of client to unregister 
 

The function returns a VARIANT_BOOL indicating success/failure. 18 

NOTE: If a QXDM filtered view was associated with the client, the view will be closed automatically by 19 

the interface. 20 
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8.2.9  ConfigureClientByKeys 1 

The ConfigureClientByKeys() function allows you to set the items an existing client is interested 2 

in processing. 3 

 
Parameter Type Description 

hClient ULONG Unique handle of client to configure 
 

The function returns an interface pointer to the QXDM client config interface model 4 

(IClientConfig) as discussed in a subsequent section. 5 

8.2.10  ConfigureClientByNames 6 

The ConfigureClientByNames() function allows you to set the items an existing client is 7 

interested in processing.  8 

 
Parameter Type Description 

hClient ULONG Unique handle of client to configure 
pConfig BSTR Space-delimited names of diag entities in which client is 

interested in processing (each name must be in quotes) 
 

The function returns a VARIANT_BOOL indicating success/failure. 9 

NOTE: The names come directly from the QXDM DIAG entity table. The format is a list of space-10 

delimited strings in quotes, i.e., “EVENT_HDR_MSG_Rx” “1xEV-DO Active Set Pilot” 11 

“1xEV-DO State” “1xEV-DO Sector.” 12 

 13 

This example indicates that the client wishes to process the event with the ID 329, and the logs 14 

with IDs 0x105F and 0x1080. When (or if) QXDM is connected to a target, it will configure the 15 

target to send the requested items. When an item arrives (either from the connected target or via 16 

QXDM playback) matching the given event or logs, it will then be added to the client. 17 

8.2.11  ClearClientItems 18 

The ClearClientItems() function allows you to empty an existing client of items.  19 

 
Parameter Type Description 

hClient ULONG Unique handle of client to empty 
 

The function returns a VARIANT_BOOL indicating success/failure. 20 

NOTE: If a QXDM filtered view was associated with the client, the view will be cleared automatically by 21 

the interface. In addition to this function, a client may be cleared when the current QXDM Item 22 

Store is emptied (as all clients are subsets of the current Item Store) or when an existing Item 23 

Store is loaded, replacing the current Item Store. 24 
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8.2.12  GetClientItemCount 1 

The GetClientItemCount() function allows you to retrieve the number of items in the specified 2 

client. This will always be a number equal to or less than the number of items in the current 3 

QXDM Item Store.  4 

 
Parameter Type Description 

hClient ULONG Unique handle of client for which to obtain count 
 

The function returns a ULONG. The ULONG return value represents the total number of items in 5 

the client (upon error 0 is returned). 6 

8.2.13  GetClientItem 7 

The GetClientItem() function allows you to retrieve a particular item from the specified client.  8 

 
Parameter Type Description 

hClient ULONG Unique handle of client from which to obtain item 
index ULONG Index of item to retrieve (the client is indexed 0 to the number of 

items returned by GetClientItemCount() – 1). 
 

The function returns an interface pointer to the QXDM item interface model (IColorItem) as 9 

discussed in a subsequent section. 10 

8.2.14  ClientRequestItem 11 

The ClientRequestItem() function allows you to schedule one or more requests to be sent through 12 

the specified client. The request itself is built according to a description entered into the QXDM 13 

database diag entity table. 14 

 
Parameter Type Description 

hClient ULONG Unique handle of client through which to request item 
pRequestName BSTR Name of diag entity (either a diag request or subsystem 

dispatch request) 
pFields BSTR Fields used to build the request 
bValuesOnly VARIANT_BOOL Does the pFields argument represent a string containing only 

the field values, or does it represent a fully qualified filename 
representing a text file containing the full field names and their 
values (e.g., generated by the QXDM Item Tester application)? 

timeout ULONG Base timeout value in milliseconds for request 
requestCount ULONG Number of requests to schedule (must be at least one) 
frequency ULONG If the requestCount argument is greater than one, then this 

represents the amount of time (in milliseconds) between 
successive requests. 

 
The function returns a unique request ID. Upon error, 0 is returned. 15 

NOTE: If bValuesOnly is VARIANT_TRUE, then the format of pFields is a space-delimited string of 16 

field values where string field values are enclosed in quotes, i.e., 0xFF 100 “A String.”  17 
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This example specifies that the first field of the request has the value 0xFF, the second field has 1 

the value 100, and the last field for the request has the value A String. For fields that are 2 

enumerations, the raw value must be provided, i.e., the integral value. 3 

 4 

If bValuesOnly is VARIANT_FALSE, then pFields is the fully qualified name of the file that 5 

gives the fields and their values. The format of the file is one field/value pair per line where the 6 

field is separated from the value by the ^ character. For an example, see the QXDM Item Tester 7 

application. 8 

 9 

The timeout argument is dependent on QPST Server. Current builds of QPST Server 10 

automatically retry each request up to three times in the case of a timeout while waiting for the 11 

response. Thus, the total timeout value is the argument value times three. Due to the real-time 12 

nature of QXDM, the maximum value for timeout is 2000 ms. 13 

If the requestCount argument value is greater than one, the request is considered to be repetitive. 14 

The first request will be scheduled to go out immediately. Subject to target latencies and the 15 

number of requests in the diag server queue, the next instance of this request will be sent out 16 

frequency ms after the response to the first request is received (or a timeout occurs). Due to the 17 

real-time nature of QXDM, the minimum value for the request frequency is currently 10 ms. A 18 

value of 0xFFFFFFFF for the request count indicates that the caller wants requests to be 19 

scheduled indefinitely. 20 

 21 

Requests and the responses to them are automatically added to the client. Thus, there is no need 22 

to register for each request and response type. Due to this it is important that the client exist for 23 

the duration of the request/response cycle. Although QXDM will continue to function if the client 24 

is removed (unregistered) prior to the request being transmitted or the response being received, 25 

relying on this behavior is not suggested. 26 

 27 

For subsystem dispatch V2 items, only the immediate response will appear in the client view. 28 

Registration for the delayed response is required for the client to receive any actual delayed 29 

response packets (see Section 8.3.7). 30 

8.2.15  ClientRemoveRequest 31 

The ClientRemoveRequest() function allows you to cancel an existing request. 32 

 
Parameter Type Description 

hClient ULONG Unique handle of client 
requestID ULONG Unique request ID 

 
The function returns a VARIANT_BOOL indicating success/failure. 33 
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8.2.16  ClientRequestNVRead 1 

The ClientRequestNVRead() function allows you to schedule a single NV item read request to be 2 

sent through the specified client. The request itself is built according to a description entered into 3 

the QXDM database diag entity table. 4 

 
Parameter Type Description 

hClient ULONG Unique handle of client through which to request item 
pNVItemName BSTR Name of diag entity to request (entity must be an NV item) 
pFields BSTR Fields used to build the request 
bValuesOnly VARIANT_BOOL Does the pFields argument represent a string containing only 

the field values or does it represent a fully qualified filename 
representing a text file containing the full field names and their 
values (such as generated by the QXDM Item Tester 
application) 

timeout ULONG Base timeout value in ms for request 
 

The function returns a unique request ID. Upon error, 0 is returned. 5 

NOTE: This function behaves in a manner consistent with the ClientRequestItem() function. 6 

8.2.17  ClientRequestNVWrite 7 

The ClientRequestNVWrite() function allows you to schedule a single NV item write request to 8 

be sent through the specified client. The request itself is built according to a description entered 9 

into the QXDM database diag entity table. 10 

 
Parameter Type Description 

hClient ULONG Unique handle of client through which to request item 
pNVItemName BSTR Name of diag entity to request (entity must be an NV item) 
pFields BSTR Fields used to build the request 
bValuesOnly VARIANT_BOOL Does the pFields argument represent a string containing only 

the field values or does it represent a fully qualified file name 
representing a text file containing the full field names and their 
values (such as generated by the QXDM Item Tester 
application)? 

timeout ULONG Base timeout value in milliseconds for request 
 

The function returns a unique request ID. Upon error 0 is returned. 11 

NOTE: This function behaves in a manner consistent with the ClientRequestItem() function. 12 
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8.2.18  CopyClientItems 1 

The CopyClientItems() function allows you to copy all or a portion of the items of a client to a 2 

new Item Store Format file. 3 

 
Parameter Type Description 

hClient ULONG Unique handle of client from which to copy items 
pFileName BSTR Filename of new Item Store Format file (.ISF) 
startIndex ULONG Client index of first item to copy 
endIndex ULONG Client index of last item to copy 

 
The function returns a VARIANT_BOOL indicating overall success/failure. 4 

The index parameters give the range of items to copy. The start index must be less than or equal 5 

to the end index. If the end index is greater than the number of items in the client, the actual index 6 

used will be one minus the number of items in the client, i.e., to always copy the entire contents 7 

of a client to the new file store without regard to the current size of the client, (0, 0xFFFFFFFF) 8 

should be specified. 9 

NOTE: This operation may take a nontrivial amount of time to complete, depending on the number of 10 

items managed by the client and the parameters to the function. While it executes, the function 11 

will not return. However, the QXDM interface will continue to respond to additional commands. 12 

Due to this, care must be taken in ensuring that the client is neither unregistered nor emptied 13 

asynchronously while a copy-items operation on the client is executing. 14 

8.2.19  SyncToItem 15 

The SyncToItem() function allows you to sync item list-based views to a given item index. 16 

 
Parameter Type Description 

Index ULONG Item Store index of the item to sync to 
bSyncExact VARIANT_BOOL If true, sync to the exact index; otherwise, sync to the nearest item 

 
The function returns a VARIANT_BOOL indicating overall success/failure. 17 

8.2.20  SyncToClientItem 18 

The SyncToClientItem() function allows you to sync a client item list-based view to a given item 19 

index. 20 

 
Parameter Type  

hClient ULONG Unique handle of client view 
Index ULONG Client index of the item to sync to 
bSyncExact VARIANT_BOOL If true, sync to the exact index; otherwise, sync to the nearest item 

 
The function returns a VARIANT_BOOL indicating overall success/failure. 21 
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8.3  Client Config Interface (IClientConfig) 1 

This section describes the QXDM client config interface (IClientConfig). 2 

8.3.1  ClearConfig 3 

The ClearConfig() function allows you to clear a client config. In the Cleared state, a client will 4 

only receive items originated through the ClientRequestItem(), ClientRequestNVRead(), and 5 

ClientRequestNVWrite() functions. This function takes no arguments and returns no value. 6 

8.3.2  CommitConfig 7 

The CommitConfig () function is typically the last function called when adjusting the config of a 8 

client. All changes made to the client config are updated within QXDM when CommitConfig() is 9 

called. This function takes no arguments and returns no value. 10 

8.3.3  AddItem 11 

The AddItem() function allows you to request that items of the specified type are added to the 12 

client as they are processed by the current QXDM Item Store. The function does not return a 13 

value. 14 

 
Parameter Type Description 

itemType ULONG Desired item type, possible values are: 
 0 – Malformed diag entity 
 1 – Target diag response (minus following) 
 2 – Target diag request (minus following) 
 3 – GPS information 
 4 – Target event 
 5 – Target log 
 6 – Target message 
 7 – Generic strings 
 8 – Target OTA log 
 9 – Target subsystem dispatch response 
 10 – Target subsystem dispatch request 

NOTE: Contrary to subsequent functions that request items of a particular subtype, this function does not 15 

actively register with the target for the given items. 16 

 17 

This form of registration is equivalent to checking an Item Type from the Item List Config of a 18 

QXDM Filtered View. 19 
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8.3.4  AddDIAGRequest 1 

The AddDIAGRequest() function allows you to request that outgoing diag requests with a 2 

specified diag command code be added to the client. The function does not return a value. 3 

 
Parameter Type Description 

cmd ULONG Diag command code of items in which client is interested 

NOTE: This is not the same as building and scheduling a request via ClientRequestItem(). This simply 4 

adds outgoing diag requests of a particular command code to the client as they are processed by 5 

the Item Store. The actual request may have originated from another QXDM subsystem. 6 

 7 

This form of registration is equivalent to the following actions in a QXDM Filtered View: 8 

1. Bring up the Item List Config dialog box. 9 

2. Check and select diag requests from the Item Types list. 10 

3. Check Filter/Register On Target For Items. 11 

4. Select a particular diag request command code from the subtype list (such as Version 12 

Information Request). 13 

In the above example, all iag requests with command code 0 would be added to the client 14 

regardless of where they originated. 15 

8.3.5  AddDIAGResponse 16 

The AddDIAGResponse() function allows you to request that incoming diag responses with a 17 

specified diag command code be added to the client. The function does not return a value. 18 

 
Parameter Type Description 

cmd ULONG Diag command code of items in which client is interested 

NOTE: This is not the same as building and scheduling a request via ClientRequestItem(). This simply 19 

adds incoming diag responses of a particular command code to the client as they are processed by 20 

the Item Store. The actual response may have originated from a diag request made by another 21 

QXDM subsystem or from QXDM playback. 22 

 23 

This form of registration is equivalent to the following actions in a QXDM Filtered View: 24 

1. Bring up the Item List Config dialog box. 25 

2. Check and select diag requests from the Item Types list. 26 

3. Check Filter/Register On Target For Items. 27 

4. Select a particular diag request command code from the subtype list (such as Version 28 

Information Request). 29 

In the above example, all diag requests with command code 0 would be added to the client 30 

regardless of where they originated. 31 
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8.3.6  AddSubsysRequest 1 

The AddSubsysRequest() function allows you to request that outgoing diag subsystem dispatch 2 

requests with a specified diag subsystem ID and subsystem command code be added to the client. 3 

The function does not return a value. 4 

 
Parameter Type Description 

subsysID ULONG Diag subsystem dispatch ID of items in which client is interested 
subsysyCmd ULONG Diag subsystem dispatch command code of items in which client is interested 

NOTE: This is not the same as building and scheduling a request via ClientRequestItem(). This adds 5 

outgoing diag subsystem dispatch requests of a particular ID and command code to the client as 6 

they are processed by the Item Store. The actual request may have originated from another 7 

QXDM subsystem. 8 

 9 

This form of registration is equivalent to the following actions in a QXDM Filtered View: 10 

1. Bring up the Item List Config dialog box. 11 

2. Check and select Subsystem Dispatch Requests from the Item Types list. 12 

3. Check Filter/Register On Target For Items. 13 

4. Select a particular subsystem ID and command code from the subtype list (such as 14 

WCDMA/Version Request). 15 

In the above example, all diag subsystem dispatch requests with subsystem ID 4 and subsystem 16 

command code 0 would be added to the client regardless of where they originated. 17 
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8.3.7  AddSubsysResponse 1 

The AddSubsysResponse() function allows you to request that incoming diag subsystem dispatch 2 

responses with a specified diag subsystem ID and subsystem command code be added to the 3 

client. The function does not return a value. 4 

 
Parameter Type Description 

subsysID ULONG Diag subsystem dispatch ID of items in which client is interested 
subsysyCmd ULONG Diag subsystem dispatch command code of items in which client 

is interested 

NOTE: This is not the same as building and scheduling a request via ClientRequestItem(). This adds 5 

outgoing diag subsystem dispatch requests of a particular ID and command code to the client as 6 

they are processed by the Item Store. The actual response may have originated from a request 7 

made by another QXDM subsystem or from QXDM playback. 8 

 9 

This form of registration is equivalent to the following actions in a QXDM Filtered View: 10 

1. Bring up the Item List Config dialog box. 11 

2. Check and select Subsystem Dispatch Responses from the Item Types list. 12 

3. Check Filter/Register On Target For Items. 13 

4. Select a particular subsystem ID and command code from the subtype list (such as 14 

WCDMA/Version Response). 15 

In the above example, all diag subsystem dispatch responses with subsystem ID 4 and subsystem 16 

command code 0 would be added to the client regardless of where they originated. 17 
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8.3.8  AddEvent 1 

The AddEvent() function allows you to request that incoming events with a specified event ID be 2 

added to the client. The function does not return a value. 3 

 
Parameter Type Description 

eventID ULONG Event ID of items in which client is interested 

NOTE: This function results in the on-target event mask (if supported) being adjusted to include the 4 

specified event ID. 5 

 6 

This form of registration is equivalent to the following actions in a QXDM Filtered View: 7 

1. Bring up the Item List Config dialog box. 8 

2. Check and select Event Reports from the Item Types list. 9 

3. Check Filter/Register On Target For Items. 10 

4. Select a particular event ID from the subtype list (such as 11 

EVENT_BAND_CLASS_CHANGE). 12 

In the above example, all events with ID 256 would be added to the client regardless of where 13 

they originated. 14 

8.3.9  AddLog 15 

The AddLog() function allows you to request that incoming logs with a specified log code be 16 

added to the client. The function does not return a value. 17 

 
Parameter Type Description 

logCode ULONG Log code of items in which client is interested 

NOTE: This function results in the appropriate on-target log mask being adjusted to include the specified 18 

log code. Also note that QXDM breaks out specific OTA log packets in order to provide 19 

additional functionality. Attempting to register from OTA log packets using AddLog() will not 20 

produce the desired behavior. 21 

 22 

This form of registration is equivalent to the following actions in a QXDM Filtered View: 23 

1. Bring up the Item List Config dialog box. 24 

2. Check and select Log Packets from the Item Types list. 25 

3. Check Filter/Register On Target For Items. 26 

4. Select a particular log code from the subtype list (such as General Temporal Analyzer). 27 

In the above example, all logs with log code 0x1019 would be added to the client regardless of 28 

where they originated. 29 
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8.3.10  AddMessage 1 

The AddMessage() function allows you to request that incoming debug trace messages with a 2 

specified subsystem ID and message level be added to the client. The function does not return a 3 

value. 4 

 
Parameter Type Description 

subsysID ULONG Subsystem ID of items in which client is interested 
level ULONG Message level (under above subsystem ID) of items in which 

client is interested 

NOTE: This function results in the appropriate on-target message mask being adjusted to include the 5 

specified debug message. 6 

 7 

This form of registration is equivalent to the following actions in a QXDM Filtered View: 8 

1. Bring up the Item List Config dialog box. 9 

2. Check and select Message Packets from the Item Types list. 10 

3. Check Filter/Register On Target For Items. 11 

4. Select a particular subsystem ID and message level from the subtype list (such as 12 

Legacy/Fatal). 13 

In the above example, all debug messages with subsystem ID 0 and message level 4 would be 14 

added to the client regardless of where they originated. 15 
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8.3.11  AddString 1 

The AddString() function allows you to request that string items of the specified subtype are 2 

added to the client as they are processed by the current QXDM Item Store. The function does not 3 

return a value. 4 

 
Parameter Type Description 

stringType ULONG Desired string item sub-type, possible values are: 
 0 – Informational string 
 1 – Warning string 
 2 – Error string 
 3 – Automation string 
 4 – Connection state string 

NOTE: This form of registration is equivalent to the following actions in a QXDM Filtered View: 5 

1. Bring up the Item List Config dialog box. 6 

2. Check and select Strings from the Item Types list. 7 

3. Check Filter/Register On Target For Items. 8 

4. Select a particular string subtype from the subtype list (such as Automation). 9 

In the above example, all strings originating from the QXDM automation subsystem (or QXDM 10 

playback of an automation string) will be added to the client. 11 

8.3.12  AddOTALog 12 

The AddOTALog() function allows you to request that incoming OTA logs with a specified log 13 

code and message type key be added to the client. The function does not return a value. 14 

 
Parameter Type Description 

logCode ULONG Log code of items in which client is interested 
key VARIANT (VT_ARRAY | VT_UI4) Message type key (specific to log code) 

NOTE: This function results in the appropriate on-target log mask being adjusted to include the specified 15 

log code. 16 
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QXDM currently treats the log codes in Table 8-1 through Table 8-6 as OTA logs. The 1 

composition of each key is provided as well. 2 

Table 8-1  OTA log codes/keys (CDMA) 3 

Code Description Key 

0x1004 CDMA access channel Single-entry array (message type) 
0x1005 CDMA reverse traffic channel Single-entry array (message type) 
0x1006 CDMA sync channel Single-entry array (message type) 
0x1007 CDMA paging channel Single-entry array (message type) 
0x1008 CDMA forward traffic channel Single-entry array (message type) 
0x1090 CDMA forward dedicated control channel Single-entry array (message type) 
0x1091 CDMA reverse dedicated control channel Single-entry array (message type) 
0x10D6 CDMA forward broadcast control channel Single-entry array (message type) 
0x10D7 CDMA reverse enhanced access channel Single-entry array (message type) 
0x10D8 CDMA forward common control channel Single-entry array (message type) 
0x1388 CDMA (from UMTS) paging channel Single-entry array (message type) 
0x1389 CDMA (from UMTS) forward traffic channel Single-entry array (message type) 
0x138B CDMA (from VoIP) paging channel Single-entry array (message type) 
0x138C CDMA (from VoIP) access channel Single-entry array (message type) 
0x138D CDMA (from VoIP) forward traffic channel Single-entry array (message type) 

 

Table 8-2  OTA log codes/keys (CDMA 1xEV-DO) 4 

Code Description Key 

0x1076 1xEV-DO access channel Two-entry array (protocol, message type) 
0x1077 1xEV-DO reverse traffic channel Two-entry array (protocol, message type) 
0x1078 1xEV-DO directed control channel Two-entry array (protocol, message type) 
0x1079 1xEV-DO forward traffic channel Two-entry array (protocol, message type) 
0x107C 1xEV-DO broadcast control channel Two-entry array (protocol, message type) 
0x1085 1xEV-DO MAC access channel Empty 
0x1086 1xEV-DO MAC control channel Empty 

 

Table 8-3  OTA log codes/keys (GSM) 5 

Code Description Key 

0x512F GSM radio resource Two-entry array (channel/direction, 
message type) 

0x5226 GSM medium access control Two-entry array (channel/direction, 
message type) 

0x5230 GSM session/mobility management Two-entry array (direction, message type) 
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Table 8-4  OTA log codes/keys (UMTS) 1 

Code Description Key 

0x713A UMTS NAS layer Two-entry array (protocol, message type) 
 

Table 8-5  OTA log codes/keys (WCDMA) 2 

Code Description Key 

0x412F WCDMA radio resource control Two-entry array (channel, message type) 
 

Table 8-6  OTA log codes/keys (Bluetooth) 3 

Code Description Key 

0x1048 Bluetooth LMP Rx Empty 
0x1049 Bluetooth LMP Tx Empty 
0x104C Bluetooth L2CAP Rx Empty 
0x104D Bluetooth L2CAP Tx Empty 
0x1052 Bluetooth RFCOMM Rx Empty 
0x1053 Bluetooth RFCOMM Tx Empty 

NOTE: This form of registration is equivalent to the following actions in a QXDM Filtered View: 4 

1. Bring up the Item List Config dialog box. 5 

2. Check and select Log Packets (OTA) from the Item Types list. 6 

3. Check Filter/Register On Target For Items. 7 

4. Select a particular log code and message type from the subtype list (such as 8 

Access/Registration). 9 

In the above example, all OTA logs with log code 0x1004 and message type 1 would be added to 10 

the client regardless of where they originated. 11 

8.3.13  AddOTALogByString 12 

The AddOTALogByString() function allows you to request that incoming OTA logs with a 13 

specified log code and message type key be added to the client. The function does not return a 14 

value. 15 

 
Parameter Type Description 

logCode ULONG Log code of items in which client is interested 
pKey BSTR Message type key (specific to log code) expressed as a string of 

space-delimited values 

NOTE: This function operates in the same fashion as AddOTALog(). The sole difference is that the 16 

message type key is passed as a string consisting of space-delimited values, i.e., “5 6 7”. The 17 

intended use is in scripting languages that do not easily support constructing and manipulating 18 

VARIANT arrays of simple types, such as VB Script and JScript. 19 

80-V1241-21 YL 137 Confidential and Proprietary – Qualcomm Technologies, Inc. 
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  

 



 COM Automation Interfaces 

8.3.14  SetSubsysV2DelayedResponsesOnly 1 

The SetSubsysV2DelayedResponsesOnly() function allows you to configure a client that will 2 

receive only the delayed subsystem dispatch V2 responses (as opposed to both the immediate and 3 

delayed responses). Since both V2 and V1 responses are treated as the same item type, this makes 4 

certain types of filtering and item processing more convenient. The function does not return a 5 

value. 6 

 
Parameter Type Description 

bDelayedOnly VARIANT_BOOL Accept only delayed responses if true 

8.4  Item Interface (IColorItem) 7 

This section describes the QXDM item interface (IColorItem). 8 

8.4.1  GetItemType 9 

The GetItemType() function allows you to retrieve the item type of the current color item. The 10 

function takes no arguments and returns a ULONG value. The ULONG return value is one of the 11 

values shown in Table 8-7. 12 

Table 8-7  GetItemType return values 13 

Value Description 

0 Malformed diag entity 
1 Target diag response (minus following) 
2 Target diag request (minus following) 
3 GPS information 
4 Target event 
5 Target log 
6 Target message 
7 Generic strings 
8 Target OTA log 
9 Target subsystem dispatch response 
10 Target subsystem dispatch request 
0xFFFFFFFF Error 

8.4.2  GetItemTypeText 14 

The GetItemTypeText() function allows you to retrieve the item type converted to a string. The 15 

function takes no arguments and returns a BSTR value. 16 

NOTE: The string returned will be identical to the contents of the Type column in any QXDM list-based 17 

view. 18 
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8.4.3  GetItemColor 1 

The GetItemColor() function allows you to retrieve the color of the current color item. The 2 

function takes no arguments and returns a ULONG value. The ULONG return value is in the 3 

form of a standard Windows COLORREF value, i.e., three 8-bit values (R, G, B) packed into a 4 

32-bit space. Upon return, (0, 0, 0) is returned. This represents black, an invalid value in QXDM, 5 

as that is the color of all item list backgrounds. 6 

8.4.4  GetItemTimestamp 7 

The GetItemTimestamp() function allows you to retrieve the generic timestamp of the current 8 

color item. The function takes no arguments and returns a standard Windows DATE value 9 

(VT_DATE). 10 

NOTE: The generic timestamp represents the time the color item was created, i.e., when it first entered 11 

the current Item Store. This is not the same as the item-specific timestamp, which is assigned to 12 

the item by the target. 13 

8.4.5  GetItemTimestamp2 14 

The GetItemTimestamp2() function allows you to retrieve the generic timestamp of the current 15 

color item. The function takes no arguments and returns a standard Windows DATE value as a 16 

double precision floating point number (VT_R8). 17 

NOTE: The generic timestamp represents the time the color item was created, i.e., when it first entered 18 

the current Item Store. This is not the same as the item-specific timestamp, which is assigned to 19 

the item by the target. 20 

8.4.6  GetItemTimestampText 21 

The GetItemTimestampText() function allows you to retrieve the generic item timestamp 22 

converted to a string. The function returns a BSTR. 23 

 
Parameter Type Description 

bWantDate VARIANT_BOOL Include the date 
bWantMillisecs VARIANT_BOOL Include ms 

NOTE: The string returned will be identical to the contents of the Timestamp column in any QXDM list-24 

based view. 25 

8.4.7  GetItemSpecificTimestamp 26 

The GetItemSpecificTimestamp() function allows you to retrieve the item-specific timestamp of 27 

the current color item. The function takes no arguments and returns a standard Windows DATE 28 

value (VT_DATE). 29 

NOTE: The item-specific timestamp represents the time assigned to the item by the target. If the item 30 

does not support a target-assigned timestamp, then the generic timestamp will be returned 31 

instead. 32 
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8.4.8  GetItemSpecificTimestamp2 1 

This function allows you to retrieve the item-specific timestamp of the current color item. The 2 

function takes no arguments and returns a standard Windows DATE value as a double precision 3 

floating point number (VT_R8). 4 

NOTE: The item-specific timestamp represents the time assigned to the item by the target. If the item 5 

does not support a target-assigned timestamp, then the generic timestamp will be returned 6 

instead. 7 

8.4.9  GetItemSpecificTimestampText 8 

The GetItemSpecificTimestampText() function allows you to retrieve the item-specific timestamp 9 

converted to a string. 10 

 
Parameter Type Description 

bWantDate VARIANT_BOOL Include the date 
bWantMillisecs VARIANT_BOOL Include milliseconds 

 
A BSTR value is returned. 11 

NOTE: The string returned will be identical to the contents of the Timestamp column in any QXDM list-12 

based view. 13 

8.4.10  GetItemBuffer 14 

The GetItemBuffer() function allows you to retrieve the raw buffer of the current color item. 15 

 
Parameter Type Description 

bIncludeHeaderBytes VARIANT_BOOL Return the full item buffer, including the QXDM-defined 
header or simply the QXDM-defined payload 

 
The function returns a VARIANT array (VT_ARRAY | VT_UI1) when successful. When an 16 

error occurs, an empty VARIANT array is returned. However, as the QXDM-defined payload 17 

may itself be empty, this is not a reliable way of determining if a true error occurred. 18 

8.4.11  GetItemDLFBuffer 19 

The GetItemDLFBuffer() function allows you to retrieve the raw buffer of the current color item 20 

adjusted to be compatible with the legacy DLF log file format. 21 

The function returns a VARIANT array (VT_ARRAY | VT_UI1) when successful. When an 22 

error occurs, an empty VARIANT array is returned. 23 
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8.4.12  GetItemBufferText 1 

The GetItemBufferText() function allows you to retrieve the raw buffer of the current color item 2 

converted to a string. The function returns a BSTR. 3 

 
Parameter Type Description 

bIncludeHeaderBytes VARIANT_BOOL Return the full item buffer, including the QXDM-defined 
header or simply the QXDM-defined payload 

NOTE: The string returned will be identical to the contents of the Payload column in any QXDM list-4 

based view. 5 

8.4.13  GetItemKeyText 6 

The GetItemKeyText() function allows you to retrieve the item key converted to a string. The 7 

function takes no arguments and returns a BSTR value. 8 

NOTE: The string returned will be identical to the contents of the Key column in any QXDM 9 

list-based view. 10 

8.4.14  GetItemName 11 

The GetItemName() function allows you to retrieve the item name. The function takes no 12 

arguments and returns a BSTR value. 13 

NOTE: The string returned will be identical to the contents of the Name column in any QXDM list-based 14 

view. The item name represents the item key mapped to a string defined in the appropriate 15 

QXDM database category/reference table. 16 

8.4.15  GetItemSummary 17 

The GetItemNameSummary() function allows you to retrieve the item summary. The function 18 

takes no arguments and returns a BSTR value. 19 

NOTE: The string returned will be identical to the contents of the Summary column in any QXDM list-20 

based view. The item summary represents a summary of the item payload generated either by 21 

internal QXDM processes, the QXDM database structure definition in combination with a 22 

QXDM database format specifier, or an external dynamic item parsing DLL. 23 

8.4.16  GetItemSize 24 

The GetItemSize() function allows you to retrieve the item size of the current color item. The 25 

function returns a ULONG value representing the size in bytes of the item. 26 

 
Parameter Type Description 

bIncludeHeaderBytes VARIANT_BOOL Return the full item size, including the QXDM-defined 
header or simply the QXDM-defined payload 
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8.4.17  GetItemParsedText 1 

The GetItemParsedText() function allows you to retrieve the item full parsed text. The function 2 

takes no arguments and returns a BSTR value. 3 

NOTE: The string returned will be identical to the contents of the bottom right pane in any QXDM  4 

list-based view (currently excludes the database parsed field list). The item full parsed text is a 5 

full description of the item payload generated either by internal QXDM processes, the QXDM 6 

database structure definition, an external dynamic item parsing DLL, or (in the case of OTA logs) 7 

SILK. 8 

8.4.18  GetItemFieldValue 9 

The GetItemFieldValue() function allows you to retrieve the actual value of a field parsed out of 10 

the item buffer. Typical applications of this function would be to parse items that cannot be 11 

described by the database or to extract fields out of the header of an item. 12 

 
Parameter Type Description 

fieldType ULONG Type of field to obtain (see Table 8-8) 
bitCount ULONG Number of bits to extract 
bitOffset ULONG Offset into item buffer to begin extraction 
bIncludeHeaderBytes VARIANT_BOOL Include the header in item buffer 

 
The function returns a VARIANT. In the case of an error, an empty VARIANT (VT_EMPTY) is 13 

returned. 14 

Table 8-8 shows the types of supported fields. 15 

Table 8-8  Supported field types 16 

Type Value VARIANT type Description 

BOOL 0 VT_BOOL Boolean (true/false) 
INT8 1 VT_I1 8-bit signed value 
UINT8 2 VT_UI1 8-bit unsigned value 
INT16 3 VT_I2 16-bit signed value 
UINT16 4 VT_UI2 16-bit unsigned value 
INT32 5 VT_I4 32-bit signed value 
UINT32 6 VT_UI4 32-bit unsigned value 
INT64 7 VT_I8 64-bit signed value 
UINT64 8 VT_UI8 64-bit unsigned value 
ANSI String 9 VT_BSTR ANSI string (fixed length given by bitCount) 
UNICODE 
String 

10 VT_BSTR UNICODE string (fixed length given by bitCount) 

ANSI String 11 VT_BSTR ANSI string (NULL terminated, bitCount ignored) 
UNICODE 
String 

12 VT_BSTR UNICODE string (NULL terminated, bitCount ignored) 

FLOAT32 13 VT_R4 IEEE 32-bit floating point value 
FLOAT64 14 VT_R8 IEEE 64-bit floating point value 
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8.4.19  GetItemFieldValueText 1 

The GetItemFieldValueText() function allows you to retrieve the text representation of the field 2 

value parsed out of the item buffer.  3 

 
Parameter Type Description 

fieldType ULONG Type of field to obtain (see Table 8-8) 
bitCount ULONG Number of bits to extract 
bitOffset ULONG Offset into item buffer to begin extraction 
bIncludeHeaderBytes VARIANT_BOOL Include the header in item buffer 
bHexadecimal VARIANT_BOOL Format field text as hexadecimal 

 
The function returns the field value as a VT_BSTR and operates in the same manner as 4 

GetItemFieldValue described above. 5 

8.4.20  GetItemFields 6 

The GetItemFields() function allows you to retrieve the QXDM structure database representation 7 

of the current color item. The function takes no arguments and returns an interface pointer to the 8 

QXDM database parsed field interface model (IColorItemFields) as discussed in Section 8.5. 9 

8.4.21  GetNamedItemFields 10 

The GetNamedItemFields() function allows you to retrieve the QXDM structure database 11 

representation of the current color item. The function takes a single argument and returns an 12 

interface pointer to the QXDM database parsed field interface model (IColorItemFields) as 13 

discussed in Section 8.5.  14 

 
Parameter Type Description 

pEntityName BSTR Unique diag entity name 
 

NOTE: The function operates in a manner consistent with GetItemFields() with the exception that a 15 

unique diag entity name is passed by the caller. The name identifies/selects the structure 16 

definition that is used to parse the current item. If the name is empty, then the function operates 17 

exactly as GetItemFields(), i.e., the default structure definition is used. The QXDM database 18 

defines default as the first structure definition added to the database for a particular diag entity 19 

key. Since the QXDM database is always loaded before any user database, this implies that the 20 

structure definition (when present) in the QXDM database is the default. Should the QXDM 21 

database not define a structure for a given diag entity key, then the default is dependant on the 22 

contents and load order of the user databases. The current QXDM behavior is for the load order 23 

to be alphabetical by user database name. Note that this behavior may change in the future. 24 
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8.4.22  GetConfiguredItemFields 1 

The GetConfiguredItemFields() function allows you to retrieve the database parsed item fields of 2 

the current color item. For applications that process a large number of items per sec or process 3 

items that parse to a large number of fields, setting bFieldStrings and/or bFieldNames to false will 4 

improve performance and/or is usually dependant on whether you need field strings or not. 5 

Generally, you only need field strings if you are dealing with a structure that contains 6 

enumerations and you need to display the mapped enumeration value strings. 7 

 
Parameter Type Description 

pEntityName LPCTSTR Diag entity name (if this is not given then the default structure 
associated with this entity will be used, i.e., GetItemFields() 
behavior) 

bFieldStrings VARIANT_BOOL Generate string representations of field values 
bFieldNames VARIANT_BOOL Generate partial field names 

 
The function returns an interface pointer to the QXDM database parsed field interface model, 8 

IColorItemFields (Section 8.5). 9 

NOTE: If bFieldStrings is set to false, retrieving the string representation of fields will not be available. If 10 

bFieldNames is set to false, searching for the index of a field by name will not be available. 11 

8.5  Field Interface (IColorItemFields) 12 

This section describes the QXDM database parsed field interface (IColorItemFields). 13 

8.5.1  GetXML 14 

The GetXML() function allows one to retrieve the database parsed fields as an XML-formatted 15 

string. The function takes no arguments and returns a BSTR value. 16 

NOTE: The format of the XML is given in the following (partial) example: 17 

 18 

<Entity> 19 

  <Name>Searcher And Finger</Name> 20 

  <Fields> 21 

    <Field> 22 

      <NamePartial>Transmit Diversity Pilot</NamePartial> 23 

      <ValueText>0</ValueText> 24 

      <ValueRaw>0</ValueRaw> 25 

      <BitSize>1</BitSize> 26 

      <BitOffset>0</BitOffset> 27 

    </Field> 28 

  </Fields> 29 

</Entity> 30 

 31 
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The intended usage of this function is in crafting simpler HTML-based QXDM views using XML 1 

transformations. In some cases, there may be an additional performance increase when using 2 

XML, as it should result in fewer COM interface classes than iterating over the list of fields. 3 

8.5.2  GetFieldCount 4 

The GetFieldCount() function allows you to retrieve the number of parsed fields generated by the 5 

database parser. The function takes no arguments and returns a ULONG value. 6 

8.5.3  GetFieldIndex 7 

The GetFieldIndex() function allows you to retrieve the index of the first field matching the 8 

specified field name. 9 

 
Parameter Type Description 

pName BSTR Name (either fully qualified or partial) of the field for which to 
find the index 

bPartial VARIANT_BOOL Is the first argument a partial field name? 
 

The function returns a ULONG that represents the index into the parsed field list matching the 10 

specified field name. The field list itself is indexed 0 up to but not including the value returned by 11 

GetFieldCount(). In the case of an error, the value 0xFFFFFFFF is returned. 12 

NOTE: For the purposes of reducing search time, subsequent calls start from one beyond the last index 13 

returned by this method. If the provided field name is not found before reaching the end of the 14 

field list, the search wraps around to the first field and proceeds until the provided field name is 15 

found or the last index returned is reached. 16 

8.5.4  GetFieldIndexFrom 17 

The GetFieldIndexFrom() function allows you to retrieve the index of the first field matching the 18 

specified field name starting the search from the provided field index.  19 

 
Parameter Type Description 

pName BSTR Name (either fully qualified or partial) of the field for which to 
find the index 

startIndex ULONG Index of field to start the search from 
bPartial VARIANT_BOOL Is the first argument a partial field name? 
bLoop VARIANT_BOOL If the field name is not found before reaching the end of the 

field list, loop back to beginning of the field list? 
 

The function returns a ULONG that represents the index into the parsed field list matching the 20 

specified field name. 21 

NOTE: The index returned affects the start index of GetFieldIndex() as described above. 22 
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8.5.5  GetFieldIndexByID 1 

The GetFieldIndexByID() function allows you to retrieve the index of the first field matching the 2 

specified field ID. The field ID is the identifier assigned to the field when it added to the DM 3 

database. 4 

 
Parameter Type Description 

fieldID ULONG ID of the field for which to find the index 
 

The function returns a ULONG that represents the index into the parsed field list matching the 5 

specified field ID. The field list itself is indexed 0 up to but not including the value returned by 6 

GetFieldCount(). In the case of an error, the value 0xFFFFFFFF is returned. 7 

NOTE: For the purposes of reducing search time, subsequent calls start from one beyond the last index 8 

returned by this method. If the provided field name is not found before reaching the end of the 9 

field list, the search wraps around to the first field and proceeds until the provided field name is 10 

found or the last index returned is reached. 11 

8.5.6  GetFieldIndexFromByID 12 

The GetFieldIndexFromByID() function allows you to retrieve the index of the first field 13 

matching the specified field ID starting the search from the provided field index.  14 

 
Parameter Type Description 

fieldID ULONG ID of the field for which to find the index 
startIndex ULONG Index of field to start the search from 
bLoop VARIANT_BOOL If the field name is not found before reaching the end of the field 

list, loop back to beginning of the field list? 
 

The function returns a ULONG that represents the index into the parsed field list matching the 15 

specified field ID. The field list itself is indexed 0 up to but not including the value returned by 16 

GetFieldCount(). In the case of an error, the value 0xFFFFFFFF is returned. 17 

NOTE: The index returned affects the start index of GetFieldIndexByID() as described above. 18 

8.5.7  GetFieldOffset 19 

The GetFieldOffset() function allows you to retrieve the bit offset of the field identified by the 20 

given field index.  21 

 
Parameter Type Description 

index ULONG Field index 
 

The function returns a ULONG representing the bit offset from the start of the QXDM-defined 22 

item payload of the specified field. In the case of an error, the value 0xFFFFFFFF is returned. 23 
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8.5.8  GetFieldSize 1 

The GetFieldSize() function allows you to retrieve the bit size of the field identified by the given 2 

field index. 3 

 
Parameter Type Description 

index ULONG Field index 
 

The function returns a ULONG. In the case of an error, the value 0xFFFFFFFF is returned. 4 

8.5.9  GetFieldValue 5 

The GetFieldValue() function allows you to retrieve the raw value of the field identified by the 6 

given field index. 7 

 
Parameter Type Description 

index ULONG Field index 
 

The function returns a VARIANT. In the case of an error, an empty VARIANT (VT_EMPTY) is 8 

returned. The QXDM structure database supports the destination field types shown in Table 8-9. 9 

Table 8-9  Supported field types 10 

Type VARIANT Type Description 

BOOL VT_BOOL Boolean (true/false) 
INT8 VT_I1 8-bit signed value 
UINT8 VT_UI1 8-bit unsigned value 
INT16 VT_I2 16-bit signed value 
UINT16 VT_UI2 16-bit unsigned value 
INT32 VT_I4 32-bit signed value 
UINT32 VT_UI4 32-bit unsigned value 
INT64 VT_I8 64-bit signed value 
UINT64 VT_UI8 64-bit unsigned value 
ANSI String VT_BSTR ANSI string 
UNICODE String VT_BSTR UNICODE string 
FLOAT32 VT_R4 IEEE 32-bit floating point value 
FLOAT64 VT_R8 IEEE 64-bit floating point value 
Signed Enum VT_I4 Signed enumeration 
Unsigned Enum VT_UI4 Unsigned enumeration 
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8.5.10  GetFieldName 1 

The GetFieldName() function allows you to name the field identified by the given field index.  2 

 
Parameter Type Description 

index ULONG Field index 
bPartial VARIANT_BOOL Return partial field name? 

 
The function returns a BSTR representing the field name. 3 

NOTE: A partial field name is equivalent to a fully qualified field name minus the leading diag entity 4 

name and field delimiter (‘.’). 5 

8.5.11  GetFieldValueText 6 

The GetFieldValueText() function allows you to retrieve the value of the field identified by the 7 

given field index expressed as a string. 8 

 
Parameter Type Description 

index ULONG Field index 
 

The function returns a BSTR. 9 

NOTE: As opposed to the field value, the field value text includes maps enums fields to their associated 10 

enum entry name. 11 

8.6  QXDM automation instances 12 

NOTE: The default behavior is for QXDM to run as a single-instance automation server (one QXDM 13 

process supports all automation clients). To run as a multi-instance automation server, QXDM 14 

must be configured using the following command line syntax: 15 

C:\<Installation Path> QXDM /MultiInstance 16 

 17 

Note that the connection model assumes a single-instance QXDM, and well-behaved DMs turn 18 

off asynchronous traffic (Logs, Messages, and Events) before disconnecting, e.g., when switching 19 

COM ports. Automation scripts must take this into account and reconfigure settings when running 20 

multi-instance sessions. 21 

Use the following command line syntax to restore QXDM as a single-instance automation server: 22 

 23 

C:\<Installation Path> QXDM /SingleInstance 24 
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8.6.1  Launching QXDM from a remote computer 1 

NOTE: Making changes to a COM application using DCOM Configuration Manager affects who can 2 

access, launch, and configure the application. 3 

It is possible to launch QXDM on a remote computer using distributed COM (DCOM). To do so, 4 

however, requires changes in the default DCOM settings on the host computer where QXDM will 5 

be running. Use the DCOMCNFG.EXE tool to give the client application permission to run 6 

QXDM: 7 

1. From the Start→Run menu, type dcomcnfg. 8 

2. Find QXDM from the applications list. If you cannot find it, QXDM has not been installed 9 

properly. 10 

 11 

Figure 8-1  Distributed COM configuration properties (Windows XP) 12 
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 1 

3. Select Properties. The QXDM Properties dialog appears. 2 
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4. Click the Location tab and select the box that configures QXDM to run on a local machine. 1 

 2 

 3 
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5. In the QXDM Properties dialog, click the Security tab and select the Customize radio button 1 

in the Access Permissions section. 2 

 3 
 

6. Grant access, launch, and configuration permissions for trusted domains by clicking the EDIT 4 

button associated with each permission control. 5 

NOTE: Specifying who can access an application may have the side effect of restricting others from 6 

running the application (even locally) on the host computer. When customizing permissions, be 7 

sure to allow all users that need to run QXDM access. The recommended approach is to add a 8 

trusted domain of users, e.g., Domain Users. Do not add single user accounts unless you know 9 

what you are doing. 10 

7. Click OK when you are finished with the Security tab. 11 

80-V1241-21 YL 152 Confidential and Proprietary – Qualcomm Technologies, Inc. 
 MAY CONTAIN U.S. AND INTERNATIONAL EXPORT CONTROLLED INFORMATION  

 



 COM Automation Interfaces 

8. Click the Identity tab and select “The interactive user” radio button. This allows QXDM to 1 

run under an interactive account. 2 

 3 
 

9. Click OK when you are finished with the Identity tab. 4 

With all other settings as default values, you are now ready to remote launch QXDM. 5 

NOTE: Be aware that if you do not specify a server name in the code when you load the QXDM object, 6 

OLE will try to load a QXDM object from the default machine specified in the DCOM setting on 7 

the local machine. 8 

 9 
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9  Runtime Parsing DLLs 1 

QXDM Pro provides an interface for users to write their own parsers to parse incoming data from 2 

the phone at runtime. Microsoft Visual Studio C++ project templates are included with QXDM 3 

installations for this purpose. Two versions are provided for compatibility with VC++ 6.0 and 4 

VC++ .NET 2003 Integrated Development Environments. A readme.txt instruction file is 5 

included in each development folder located where QXDM is installed. Refer to this file for 6 

instructions on setting up and using the template projects to build custom runtime parser DLLs. 7 

C:\Program Files\Qualcomm\QXDM\ParsingDLLWizard\Vc2005 8 

C:\Program Files\Qualcomm\QXDM\ParsingDLLWizard\Vc2003 9 

C:\Program Files\Qualcomm\QXDM\ParsingDLLWizard\Vc6 10 

 11 
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10  Frequently Asked Questions 1 

Q What do I do when QXDM reports that it cannot load the Parser.dll? The error display is: “The specified module 
could not be found.” 

A The DLL depends on another DLL that cannot be found on the target machine. You need to use a tool such as 
Depends or Dumpbin to better understand the dependencies of your DLL before trying to run it on other 
machines. 

 
Q What do I do if the phone is not sending the logs I requested? 

A In order for the logs of interest to be sent, the target has to be notified.  In QXDM, this is accomplished with the 
opening of a display window (maximized or minimized) which uses these logs.  This action registers the logs 
with QXDM and notifications will be sent to the target.  The window must remain open in order for the target to 
continue sending said logs.  Ensure that the configuration of the registering view has the log selected. Verify 
that QXDM has registered the logs using View Registrations (File →View Registrations). If the log is checked, 
then contact the responsible phone technology or build person for help in determining why the phone is not 
sending the log. 

 
Q Why doesn’t the Log View display appear when I select it from the View combo-box or press <ALT + L>? 

A The Log View appears only if QXDM is connected to a phone. 

 
Q When I start QXDM, why do I get DB Merge warnings? 

A When merging user databases, QXDM reports any conflicts or errors. Refer to [Q6] for help on editing user 
databases. 

 
Q The Load Items and Replay Items menu options are disabled in the File menu. How do I load an existing Item 

Store Format (.ISF) file? 

A You cannot replay or load an Item Store while connected to a phone. In the Options menu, select 
Communications and make sure that the Target Port is disconnected. 

 
Q How do I show or hide certain columns in the Item view or Filtered view? 

A Right-click the view to display the context menu and then click the Appearance option. Check or uncheck the 
box beside the column names to show or hide them. 
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Q How do I save my QXDM session into an Item Store Format (.ISF) file for loading or replaying at a later time? 

A In the File menu, select Save Items to immediately save the current session. Alternatively, check Enable Query 
For ISF Save (Figure 3-9) to cause the session to be saved. When checked, QXDM will prompt for a path in 
which to save the .ISF file, upon exiting. 

 
Q How do I save my configuration of open displays and registered items? 

A When QXDM is open, it will open the same displays and register interest in the same items that were in the 
previous QXDM session. If you have multiple configurations that you would like to preserve, use the Save 
Configurations and Load Configurations options in the File menu to save and load QXDM configurations (see 
Section 3.1.4). 

 
Q Is there any way to exclude displays from the View Bar and View menu? 

A Yes, create a file named UserDisplayExclusions.txt in the QXDM database folder (typically located at 
C:\Documents and Settings\All Users\Documents\Qualcomm\QXDM\Database). Add to the contents of the file 
the name of each QXDM display (one per line) that is to be excluded from the View Bar and View menu and 
then restart QXDM. 

 1 
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